Here's the trick- Edit the file
<gumstix-oe>/com.gumstix.collection/packages/robostix/ --
change this line
SRC_URI = "svn://;module=robostix;rev=1588;proto=http
to this
SRC_URI = "svn://;module=robostix;rev=1588;proto=http

Note the "root:root@" part in the modified line...


On Thu, May 29, 2008 at 12:17 PM, ericwade <> wrote:

Hello all ... I keep seeing references to the 'root:root' fix for bitbaking

My question ... what exactly needs to be changed in the file?

Is it (1):

install -m 0755 -d ${D}/root --> install -m 0755 -d ${D}/root:root

or (2):

FILES_${PN}-avr-ArgTest = "/root/argTest.hex" --> FILES_${PN}-avr-ArgTest =

When I tried (1), there was no change (meaning, bitbake robostix did not
create all the .ipk files).
When I tried (2), I got the error:
Error: Package name contains illegal characters (the `:', I'm assuming).

Any help? Thanks!

View this message in context:
Sent from the Gumstix mailing list archive at

This email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
gumstix-users mailing list