I have a somewhat old (6ish months) which had an older root fs (and of course linux kernel), that dated prior to module support being a part of the package. I am now back on a project using the Gumstix and am in need of loadable kernel module support. In the process of getting there, I seem to have broken a few things though, and hope someone can help me.
Today I downloaded the complete tool package and was able to build everything without any issues. I then copied the root_fs_arm to my MMC card (using wget on the older root_fs) without problem. Finally, I was able to use uboot to install the new root_fs_arm without any issues, and booting worked as well. After booting I am able to verify that the proper root fs is there, based on the kernel label in uname -a, and the fact that mod utilities are present.
I am having two problems however. First, and less important I think - my 32Mb MMC card (provided by Gumstix) seems to not be recognized by the system anymore:
    # ls -l /dev/mmc/mmc0/part1
    brw-r-----    1 root     root     254,   1 Dec 15  2004 /dev/mmc/mmc0/part1
    # mount /mnt/mmc
    mount: Mounting /dev/mmc/mmc0/part1 on /mnt/mmc failed: No such device
More important to me, but perhaps more trivial to fix? I do not have a bluetooth device, but the default root fs is created to want to load bluetooth. No issues with that, but it seems to no longer load the pieces required to restablish my USB network through RNDIS. I have tried loading all three modules from /lib/modules/2.6.9-rc1-gum/kernel/drivers/usb/gadget (in the order that worked after trial and error), used ifconfig to set up my (static) ip address, and I also used "ifconfig usb0 up" afterwards. The last few lines of my dmesg at this point is:
    usb0: Ethernet Gadget, version: St Patrick's Day 2004
    usb0: using pxa2xx_udc, OUT ep2out-bulk IN ep1in-bulk STATUS ep6in-bulk
    usb0: MAC ae:bf:ea:fd:19:a6
    usb0: HOST MAC 9e:d0:54:aa:6c:9e
    usb0: RNDIS ready
However, Windows XP is no longer seeing the device when it is plugged in, so I cannot establish the network connection. (The connection established without flaw prior to updating my root fs, and of course nothing on the Windows side has changed.) I suspect there's just something silly I'm missing.
Any help would be greatly appreciated. Thanks much!

NOTE: The information in this message is intended for the personal and confidential use of the designated recipient(s) named above. To the extent the recipient(s) is/are bound by a non-disclosure agreement, or other agreement that contains an obligation of confidentiality, with AuthenTec, then this message and/or any attachments shall be considered confidential information and subject to the confidentiality terms of that agreement.  If the reader of this message is not the intended recipient named above, you are notified that you have received this document in error, and any review, dissemination, distribution or copying of this message is strictly prohibited. If you have received this document in error, please delete the original message and notify the sender immediately. Thank you.
AuthenTec, Inc. www.authentec.com