Hi Robin,

did you check out the following tutorial by Scott Ellis?

There is some note regarding the devmem2 approach for kernel versions > 2.6.39
NOTE: The devmem2 procedure won't work with kernel 2.6.39 or greater. The source clocks for PWM are now disabled by default and have to be explicitly enabled before the timer registers can be accessed. The devmem2 steps below do not do this. Refer to the omap3-pwm driver and look for pwm_enable_clock() in pwm.c to see how to enable the clocks in a driver.
Hope that helps.
Btw.: the omap3-pwm driver works like a charm!


-------- Original Message  --------
Subject: [Gumstix-users] Overo devmem2 bus error
From: Robin Moss <robin_moss@btinternet.com>
To: gumstix-users@lists.sourceforge.net
Date: 08/28/2012 11:34 PM



I’ve been looking around and fiddling but haven’t been able to fix this issue. I’m trying to get PWM working, I have some code that worked before on an Overo-Air but with my new one it doesn’t work.



devmem2 0x48088024 w 0x00000000

Gives me a Bus error


I have google quite a few things and have tried the following:

•             CONFIG_OMAP_RESET_CLOCKS – Disabling this in the kernel config (via menuconfig)

•             ARCH_HAS_HOLES_MEMORYMODEL – This is enabled in the config


Just to make sure I'm actually compiling the kernel right (with new config)


Bitbake –c menuconfig virtual/kernel

cp ${OVEROTOP}/tmp/work/overo-angstrom-linux-gnueabi/linux-omap3-3.2-r103git/.config \


Bitbake –c clean virtual/kernel

Bitbake virtual/kernel

Bitbake omap-console-image


Then I flash the nand with the compile images in:



If anyone has any suggestions as it if I'm doing the build/config wrong or what I need to fix in my config I would really appreciate it.