Hi Christian

Apply the updated openssh.patch I just posted and recompile openssh (you might have to delete the configure script)
Uncomment the SFTPSERVER_PATH in dropbear's options.h & recompile.
On the Gumstix: Copy sftp-server to the location defined by SFTPSERVER_PATH.
This should make it, but let me know if you have any problems.

You might also use sshd, which works for me, but I haven't tried it with sftp-server yet.

I'll post a patch for the options.h file later.

Cheers
Rasmus


2007/9/18, Christian Faure <christian.faurebouvard@laposte.net>:
Hi Rasmus,

Can you place a brief description or a mini howto of steps
to enable sftp on verdex?

I've tried, but only get a segmentation fault

Thanks
Christian

El Lunes, 17 de Septiembre de 2007 13:28, Craig Hughes escribió:
> On Sep 11, 2007, at 12:55 PM, Rasmus Kjeldsen wrote:
> > Hi All
> >
> > Does anybody know why the SFTPSERVER_PATH is commented out by the
> > dropbear-options.patch?
> >
> > I wanted to be able to sftp to my Verdex, and restored the
> > SFTPSERVER_PATH (to /usr/sbin/sftp-server), and
> > fixed a build-error in openssh: http://sourceforge.net/mailarchive/
> > message.php?msg_name=6e690d2f0708140713s64a8dd5fwe1846aca797b63e9%
> > 40mail.gmail.com
> >
> > And now sftp to the Verdex works.
> >
> > Can I send some patches so the Gumstix Subversion repository can be
> > updated? To whom do I send them?
>
> To me/the list please.
>
> Thanks
>
> C


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users