On 8/12/2010 5:17 PM, Darren wrote:
So skipping ahead a little I do a sudo dpkg-reconfigure dash and answer NO to the question to remove the dash symlink.

Then I try to start installing the package listed, starting with sed.

The instructions tell me to do "aptitude install sed".  That fails for me because I'm not root, so I do a "sudo aptitude install sed".

So the instructions should be updated to use sudo.

I do a "sudo aptitude install sed" and I get
"sudo: aptitude: command not found"

So I do a "sudo apt-get install aptitude" to install aptitude.

Now "sudo aptitude install sed" runs but tells me that sed is already installed.

Now onto the rest of the packages:
"sudo aptitude install wget"  informs me wget is already installed
"sudo aptitude install cvs" OK
"sudo aptitude install subversion" OK
"sudo aptitude install git-core" OK
"sudo aptitude install coreutils" informs me coreutils is already installed
"sudo aptitude install unzip" informs me unzip is already installed
"sudo aptitude install texi2html" OK
"sudo aptitude install texinfo" OK
"sudo aptitude install docbook-utils"  OK--installs 200 MB of stuff, yikes.
"sudo aptitude install gawk" OK
"sudo aptitude install python-pysqlite2" OK
"sudo aptitude install diffstat" OK
"sudo aptitude install help2man" OK
"sudo aptitude install make"  informs me make is already installed
"sudo aptitude install gcc"  informs me gcc is already installed
"sudo aptitude install build-essential" OK
"sudo aptitude install g++"  informs me g++ is already installed
"sudo aptitude install desktop-file-utils"  informs me desktop-file-utils is already installed
"sudo aptitude install chrpath" OK

The next ambiguous step:

"On debian you may have to run
 update-alternatives --config git (as root)

and select /usr/bin/git-scm to provide git instead of /usr/bin/git.transition. This is not necessary in sid"

I try running the command and am told "error: no alternatives for git"

The instructions offer no explanation as to whether this is a good or bad outcome....does this mean I can skip this step?

I guess I'll skip it and hope it's not important.

Now onto supplemental packages.  No mention that even though they are supplemental they are still required...are they?  I guess I'll assume they are.

sudo apt-get install libxml2-utils OK
sudo apt-get install xmlto OK  holy smokes--375 Mb more stuff--Not sure why I need over 1/2 a gig (and counting) of docbook/latex/fonts to compile an app for an embedded system with 256Mb of flash.  Do I need all this stuff to build a headless (console only) gumstix image?  Is there any way to minimize the install?

sudo apt-get install python-psyco OK
sudo apt-get install apr FAILS  "E: Unable to locate package apr" 

NOT sure what to do here..will move on and see what happens

apt-get install docbook is listed as optional so I am skipping it.

Skipping the "Building in container (LXC/OpenVZ)" step because I have no idea what it means.

Next I am told "you can also install Psyco Python JIT compiler to speed up BitBake. Psyco works on 32-bit x86 platforms only. "aptitude install python-psyco""

But I have already installed python-psyco in an earlier step.

Next I am told "there are known gcc issues in Intrepid and later when cross-compiling with OE"  Is this still an issue?  Right after this statement there is a [SOLVED] statement but I can't tell if that applies to the gcc issues or the next item.  Can anyone enlighten me?

Next "cat /proc/sys/vm/mmap_min_addr" reveals a value of 65536 which appear to indicate I don't have to worry about qemu workarounds...

So apparently NOW I am ready to follow the directions at "http://www.gumstix.net/Setup-and-Programming/view/Overo-Setup-and-Programming/Setting-up-a-build-environment/111.html"?

So NOW I am given a big list of packages I supposedly need starting with git and svn.  According to the docs the only two I need up front are git and svn.  If any others are actually needed I will be prompted along the way.  I will take that at face value and not install anything at this point since git and svn were installed earlier.

So now onto overo specifics which all seem to work OK without errors:

mkdir -p ~/overo-oe
cd ~/overo-oe
git clone git://gitorious.org/gumstix-oe/mainline.git org.openembedded.ev
git checkout --track -b overo origin/overo
cd ~/overo-oe
git clone git://git.openembedded.net/bitbake bitbake
cd bitbake
git checkout 1.8.18
cd ~/overo-oe
cp -r org.openembedded.dev/contrib/gumstix/build .
source ~/overo-oe/build/profile

Now the big test.  I'm still in ~/overo-oe when I run:

bitbake omap3-console-image

And it goes through with the bitbake this time!

But then I get the message:

ERROR: Required build target 'omap3-console-image' has no buildable providers.
Missing or unbuildable dependency chain was: ['omap3-console-image', 'opkg-native', 'help2man-native', 'perl-native-runtime-native']

Had that problem last week

edit /user/overo/build/site.conf
and add
ASSUME_PROVIDED +="help2man-native"
bitbake omap3-console-image


UTS CRICOS Provider Code: 00099F
DISCLAIMER: This email message and any accompanying attachments may contain confidential information. If you are not the intended recipient, do not read, use, disseminate, distribute or copy this message or attachments. If you have received this message in error, please notify the sender immediately and delete this message. Any views expressed in this message are those of the individual sender, except where the sender expressly, and with authority, states them to be the views the University of Technology, Sydney. Before opening any attachments, please check them for viruses and defects.