Hi Dave,

This one is really perplexing me.
I have taken a standard build from the verdex oe tree http://www.gumstix.net/wiki/index.php?title=Verdex_Git_Repository
Still the same issue.
I have dumped the pxaregs and diffed them with the pxaregs from the 2.6.21 build and ran a script to align them as much as possible.
Still the same.
I have tried patching the kernel in arch/arm/mach-pxa/gumstix-verdex.c.
I thought that it may be related to the MMC so I stripped the kernel down and installed on compact flash.
Still the same.
I tried on another GPIO but seems to be a general issue. (On at lease 2 GPIO'S)

The reason I need to go from 2.6.21 to 2.6.31 is the USBnet driver works better on 2.6.31 otherwise I would stay on 2.6.31.


Grahame Jordan

On 23/07/10 02:33, Dave Hylands wrote:
HI Grahame,

On Wed, Jul 21, 2010 at 11:09 PM, Grahame Jordan <gbj@theforce.com.au> wrote:

I have a problem with GPIO on Verdex OE for the Kernel 2.6.31 version.
I do not have this problem with the older gumstix OE repository for
kernel 2.6.21

I have a switch on GPIO_66
When I press this switch the gumstix halts

I run pxaregs to set the pin as Falling edge detect.

# Set the pin to GPIO
pxaregs GAFR2L_66 0
# Set the ping to input
pxaregs GPDR2_66 0
# Set the ping to detect falling edge
pxaregs GFER2_66 1

When button is pressed ie. level is set low the gumstix freezes
If I do not use either falling or rising level detection it works OK

What is going on here?
My guess is that it's causing an interrupt which isn't being handled
because the gpio ISR had no idea that somebody was enabling an new
interrupt. Did you install an ISR handler?


Glass Expansion
15 Batman Street
West Melbourne
Victoria 3003
T: +61 3 9320 1111
F: +61 3 9320 1112

Click here to check out our new TruFlo Sample Monitor