Hey =)

If says -
No lease, failing
no correct IP has been obtained, you can try to set the IP manually - ifconfig wlan0 192.168.x.x

There actually was a discussion about the DHCP failing in the lastest versions.
You might be connected, and just not get a correct IP to work with.


Bernhard Wörndl-Aichriedler

Am 17.05.2010 21:32, schrieb vwyodapink:
Overo Fire
Summit expansion board
Connected by console 
on board V Jan 13 2010
SD Card has most current down-loadable desktop version

>From searching through here on the site I have been able to get my over fire
to connect with wifi to my router with no key. Has a ipv6 address router
shows its connected, but I cant ping or update or anything. What could be
causing this? 

I have also tried loading the most current desktop image on my SD card and
have gotten to the same end result everything appears to be connected but it
appears as if something is blocking it. It also shows that the lease is
failing but it is getting an IP. Let me know if I can post any other
particular info to help diagnose. 

Though it will not stay connected for very long and if I do ifdown wlan0
then ifup wlan0 it will occasionally connected again to the router but then
it will still not ping anything nor will it stay connected. 

Here are the only things I can find that seem relevant 

U-Boot 2009.11 (Jan 13 2010 - 07:00:40)

OMAP3530-GP ES3.1, CPU-OPP2 L3-165MHz
Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  256 MB
NAND:  256 MiB
*** Warning - bad CRC or NAND, using default environment

though from what I found in one post someone said this OK, is that correct?

And here is wifi related:
Starting udev
udev: starting version 141
ads7846 spi1.0: touchscreen, irq 274
ads7846 spi1.0: no device detected, test read result was 0x00000000
lib80211: common routines for IEEE802.11 drivers
libertas_sdio: Libertas SDIO driver
libertas_sdio: Copyright Pierre Ossman
libertas_sdio mmc1:0001:1: firmware: requesting sd8686_helper.bin
libertas_sdio mmc1:0001:1: firmware: requesting sd8686.bin
Remounting root file system...
NET: Registered protocol family 10
libertas: 00:50:43:02:fe:01, fw 9.70.3p24, cap 0x0000030b
libertas: wlan0: Marvell WLAN 802.11 adapter
ALSA: Restoring mixer settings...
Configuring network interfaces... ADDRCONF(NETDEV_UP): wlan0: link is not
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
udhcpc (v1.13.2) started
run-parts: /etc/udhcpc.d/00avahi-autoipd exited with code 1
Sending discover...
Sending select for
Sending select for
Sending select for
No lease, failing
Starting portmap daemon: portmap.
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
net.ipv4.ip_forward = 1
Turning echo off on /dev/ttyS1
INIT: Entering runlevel: 5
Starting system message bus: dbus.
Starting Hardware abstraction layer hald
Starting OpenBSD Secure Shell server: sshd
Starting advanced power management daemon: No APM support in kernel
Starting ntpd: done
Starting syslogd/klogd: done
 * Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon
[ ok ]
Starting Bluetooth subsystem:
CSR build ID 0x0C-0x5C
Device setup complete
 ttyS1 bluetoothd hid2hci rfcomm.
Waiting for connection on channel 1
Starting Network connection manager daemon: NetworkManager.
Starting PVR
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Starting GPE display manager: gpe-dm

Thanks for any help on this