Hey all,
    Sorry if this question has been covered before, but I couldn't find any solution in the archive. I also apologize if the answer is obvious. So here is my situation. I have the Verdex PRO COM, and I am trying to just get it going. I just want to connect to it and send maybe a simple Hello World. I am following the directions 'Setting up a build Environment' on the gumstix site. I make it as far as the "bitbake omap3-console-image" command. When I run this I get this error:

socks@ubuntu:~$ bitbake omap3-console-image
Traceback (most recent call last):
  File "/home/socks/overo-oe/bitbake/bin/bitbake", line 143, in <module>
    main()
  File "/home/socks/overo-oe/bitbake/bin/bitbake", line 123, in main
    cooker.parseConfiguration()
  File "/home/socks/overo-oe/bitbake/lib/bb/cooker.py", line 68, in parseConfiguration
    self.parseConfigurationFile( os.path.join( "conf", "bitbake.conf" ) )
  File "/home/socks/overo-oe/bitbake/lib/bb/cooker.py", line 402, in parseConfigurationFile
    bb.fetch.fetcher_init(self.configuration.data)
  File "/home/socks/overo-oe/bitbake/lib/bb/fetch/__init__.py", line 100, in fetcher_init
    pd.delDomain("BB_URI_HEADREVS")
  File "/home/socks/overo-oe/bitbake/lib/bb/persist_data.py", line 70, in delDomain
    self.connection.execute("DROP TABLE IF EXISTS %s;" % domain)
sqlite3.OperationalError: attempt to write a readonly database

What did I do wrong?

And to help you to help me, a bunch of information relating to this that you might need.

- I'm am totally new to Linux(and the whole Linux idea), but have a good understanding of computer programming and how computers work (under-the-hood, so to speak)
- I'm running VMware Player to use Ubuntu 9.10
- Box Specs: 2.81 GHz AMD Athlon 64 FX-62, 2 GB RAM, 500 GB HDD
- VM Specs: 1002.5 MB RAM, 20 GB HDD
- I followed the directions in the 'Setting up a build environment' page in this order:
    1)Installed all the required packages (git, subversion, etc.)
    2)Linked /bin/sh to bash
    3)Added two lines to /etc/sysctrl.conf
    4)Created '/overo-oe' directory
    5)'Git'ed OE metadata into this directory and checkout
    6)Installed Bitbake and checkout
    7)Copied OE config files
    8)Set up bash profile (Option A) and restarted Terminal
    9)The command 'bitbake omap3-console-image' fails with above error

    I then read around here, was advised to go back to the 'OE and your distro' page, and did this:
    1)Installed libsdl1.2-dev (missing before when it failed because I thought the 1 was a l (L))
    2)Installed supplimentary packages
    3)Installed docbook
 Still same error. I'm sure if I rummaged around enough I could find the file and change it's permissions but something tells me that is not the root of the problem. I saw one other guy on here that had a similar problem, but no resolution was listed.

Any ideas?