I have a related question.  I too downloaded the latest buildroot, compiled a hello.c, and moved to the mmc card.  Segmentation fault.  So, following the advice of the Wiki, I downloaded the r773 buildroot.  That worked.  So now I've got a valid toolchain and can compile happily.

My question, however, is how do I compile other packages I'm interested in?  Unless I'm missing something the r773 trunk didn't include any packages.  I've still got the other buildroot in a different directory, but how do I make sure that whatever I compile uses the r773 version of arm-linux-gcc compiler?

Thanks.

On 4/5/06, Peter Darling <pdarling@pcrs.net> wrote:
Hey Warren,

What was the command you used to compile hello.c?

-Peter

On 4/4/06, Warren Loomis <wloomis@forwardface.com> wrote:
>
> I've downloaded the development environment, compiled hello.c, moved the
> executable to the gumstix waysmall using the mmc card. When try to execute
> on the gumstix get Segmentation fault. The programming page sez that a batch
> of gum boards was shipped with version 773 and suggests getting the older
> version, so I
>
> svc co -r 773
> http://svn.gumstix.com/gumstix-buildroot/trunk
> gumstix-buildroot
> cd gumstix-buildroot
> make
>
> Did this, recompiled, moved to the mmc card and tried again, and got the
> same Segmentation fault message.
>
> Anyone have any suggestions?
>
> Thanks, Warren
>
>
> Warren Loomis
> 55 Wallace Farm Road
> Norwich, Vermont 05055
> 802 649 1656
> wloomis@forwardface.com
>


--
Peter Darling
pdarling@pcrs.net


-------------------------------------------------------
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
http://sel.as-us.falkag.net/sel?cmdlnk&kid0944&bid$1720&dat1642
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users