I'm setting up a build environment following the instructions on gumstix.net for "Setup and Programming" for the Overo.

After including the epel and rpmfusion repositories (so that I could install some missing packages), I was finally able to get bitback to start it's process:

bitbake omap3-console-image

 

| checking for DEPENDENT_WITH_XML... yes checking for

| DEPENDENT_WITH_GTK... no checking for DEPENDENT_WITH_XML_AND_GTK... no

| checking for DEFAULTS... yes checking for

| polkit-policy-file-validate... no

| configure: error: polkit-policy-file-validate not found

| FATAL: oe_runconf failed

NOTE: Task failed: /home/dknovic/overo-oe/tmp/work/armv7a-angstrom-linux-gnueabi/gconf-2.26.2-r1/temp/log.do_configure.2649

ERROR: TaskFailed event exception, aborting

ERROR: Build of /home/dknovic/overo-oe/org.openembedded.dev/recipes/gnome/gconf_2.26.2.bb do_configure failed

ERROR: Task 2737 (/home/dknovic/overo-oe/org.openembedded.dev/recipes/gnome/gconf_2.26.2.bb, do_configure) failed

NOTE: Tasks Summary: Attempted 826 tasks of which 826 didn't need to be rerun and 1 failed.

ERROR: '/home/dknovic/overo-oe/org.openembedded.dev/recipes/gnome/gconf_2.26.2.bb' failed



...so I'm missing polkit-policy-file-validate...

Using rpmfind, I see it's in PolicyKit...



However, it doesn't seem to exist for RHEL:

yum provides *polkit*

Loaded plugins: kmdl, rhnplugin, security

No Matches found



Doesn't help, and grabbing the PolicyKit for FC11, FC10, or FC09 produces:

rpm -Uhv ~/Desktop/PolicyKit-0.9-4.fc11.i386.rpm

error: Failed dependencies:

        libc.so.6(GLIBC_2.8) is needed by PolicyKit-0.9-4.fc11.i386

        libexpat.so.1 is needed by PolicyKit-0.9-4.fc11.i386

        hal < 0.5.10-3.fc11 conflicts with PolicyKit-0.9-4.fc11.i386




Anyone else using Red Hat Enterprise?  Any thoughts on ways around the problem?

 
David Novick
dknovick@yahoo.com