So skipping ahead a little I do a sudo dpkg-reconfigure dash and answer NO to the question to remove the dash symlink.

Then I try to start installing the package listed, starting with sed.

The instructions tell me to do "aptitude install sed".  That fails for me because I'm not root, so I do a "sudo aptitude install sed".

So the instructions should be updated to use sudo.

I do a "sudo aptitude install sed" and I get
"sudo: aptitude: command not found"

So I do a "sudo apt-get install aptitude" to install aptitude.

Now "sudo aptitude install sed" runs but tells me that sed is already installed.

Now onto the rest of the packages:
"sudo aptitude install wget"  informs me wget is already installed
"sudo aptitude install cvs" OK
"sudo aptitude install subversion" OK
"sudo aptitude install git-core" OK
"sudo aptitude install coreutils" informs me coreutils is already installed
"sudo aptitude install unzip" informs me unzip is already installed
"sudo aptitude install texi2html" OK
"sudo aptitude install texinfo" OK
"sudo aptitude install docbook-utils"  OK--installs 200 MB of stuff, yikes.
"sudo aptitude install gawk" OK
"sudo aptitude install python-pysqlite2" OK
"sudo aptitude install diffstat" OK
"sudo aptitude install help2man" OK
"sudo aptitude install make"  informs me make is already installed
"sudo aptitude install gcc"  informs me gcc is already installed
"sudo aptitude install build-essential" OK
"sudo aptitude install g++"  informs me g++ is already installed
"sudo aptitude install desktop-file-utils"  informs me desktop-file-utils is already installed
"sudo aptitude install chrpath" OK

The next ambiguous step:

"On debian you may have to run
 update-alternatives --config git (as root)

and select /usr/bin/git-scm to provide git instead of /usr/bin/git.transition. This is not necessary in sid"

I try running the command and am told "error: no alternatives for git"

The instructions offer no explanation as to whether this is a good or bad outcome....does this mean I can skip this step?

I guess I'll skip it and hope it's not important.

Now onto supplemental packages.  No mention that even though they are supplemental they are still required...are they?  I guess I'll assume they are.

sudo apt-get install libxml2-utils OK
sudo apt-get install xmlto OK  holy smokes--375 Mb more stuff--Not sure why I need over 1/2 a gig (and counting) of docbook/latex/fonts to compile an app for an embedded system with 256Mb of flash.  Do I need all this stuff to build a headless (console only) gumstix image?  Is there any way to minimize the install?

sudo apt-get install python-psyco OK
sudo apt-get install apr FAILS  "E: Unable to locate package apr" 

NOT sure what to do here..will move on and see what happens

apt-get install docbook is listed as optional so I am skipping it.

Skipping the "Building in container (LXC/OpenVZ)" step because I have no idea what it means.

Next I am told "you can also install Psyco Python JIT compiler to speed up BitBake. Psyco works on 32-bit x86 platforms only. "aptitude install python-psyco""

But I have already installed python-psyco in an earlier step.

Next I am told "there are known gcc issues in Intrepid and later when cross-compiling with OE"  Is this still an issue?  Right after this statement there is a [SOLVED] statement but I can't tell if that applies to the gcc issues or the next item.  Can anyone enlighten me?

Next "cat /proc/sys/vm/mmap_min_addr" reveals a value of 65536 which appear to indicate I don't have to worry about qemu workarounds...

So apparently NOW I am ready to follow the directions at ""?

So NOW I am given a big list of packages I supposedly need starting with git and svn.  According to the docs the only two I need up front are git and svn.  If any others are actually needed I will be prompted along the way.  I will take that at face value and not install anything at this point since git and svn were installed earlier.

So now onto overo specifics which all seem to work OK without errors:

mkdir -p ~/overo-oe
cd ~/overo-oe
git clone git:// org.openembedded.ev
git checkout --track -b overo origin/overo
cd ~/overo-oe
git clone git:// bitbake
cd bitbake
git checkout 1.8.18
cd ~/overo-oe
cp -r .
source ~/overo-oe/build/profile

Now the big test.  I'm still in ~/overo-oe when I run:

bitbake omap3-console-image

And it goes through with the bitbake this time!

But then I get the message:

ERROR: Required build target 'omap3-console-image' has no buildable providers.
Missing or unbuildable dependency chain was: ['omap3-console-image', 'opkg-native', 'help2man-native', 'perl-native-runtime-native']

From: Darren <>
To: General mailing list for gumstix users. <>
Sent: Tue, December 7, 2010 11:44:34 PM
Subject: Re: [Gumstix-users] Please help--I'm unable to get a build environment working

OK I'm going to try a from scratch (4th time!) install.  I'm a little frustrated right now.  I've been using Linux since Linus was in college and you got distros on floppies.  I feel like there should be a 100% clear set of instructions (i.e. a cold-start procedure) that any first time user will be able to ace, let alone a 20 year veteran.  So in the interest of developing those instructions I will log my all of my steps and post to the list anytime there is an error or question.  

I am going to start a fresh ubuntu 10.10 i386 32 bit install in the latest virtualbox on my quad core windows vista 64 bit machine.  I will give the VM 512 MB of ram and a dynamic 60 Gig hard virtual hard drive formatted with ext4.

I'm choosing standard USA defaults and a username of dhumphre.

OK the virtualbox image is installed and booted.

I'm logging in as dhumphre and opening a terminal.  I will start by following the instructions on 

OK. So here's the first point in the instructions that are not 100% unambiguous:

Should I do this:  "The easiest way is via apt-get'able Openembedded which will pull the OE meta-data for you and keep it up-to-date."  

Or should I follow the directions and do: 
"aptitude install sed wget cvs subversion git-core \
   coreutils unzip texi2html texinfo docbook-utils \
   gawk python-pysqlite2 diffstat help2man make gcc build-essential g++ \
   desktop-file-utils chrpath

From: Darren <>
To: General mailing list for gumstix users. <>
Sent: Tue, December 7, 2010 11:13:05 PM
Subject: Re: [Gumstix-users] Please help--I'm unable to get a build environment working

I did follow both notes 1 & 2.  On my first vm I did install the packages you mention here...on the most recent vm I installed the packages listed on
.  I take it I need to also do what is at

From: Alex Gibson <>
To: General mailing list for gumstix users. <>
Sent: Tue, December 7, 2010 11:06:31 PM
Subject: Re: [Gumstix-users] Please help--I'm unable to get a build environment working

Have you installed the required packages as described here
make sure in install both mandatory and supplementary packages

aptitude install sed wget cvs subversion git-core \
   coreutils unzip texi2html texinfo docbook-utils \
   gawk python-pysqlite2 diffstat help2man make gcc build-essential g++ \
   desktop-file-utils chrpath
update-alternatives --config git (as root)
apt-get install libxml2-utils xmlto python-psyco apr
apt-get install docbook

and did you exactly follow notes 1 and 2 ? Note 2 is needed on most distros.

Note 1: If you are using an Ubuntu distribution, it is likely that /bin/sh is linked to /bin/dash. If this is the case, then you will need to change /bin/sh to link to /bin/bash. Neglecting to do this will cause target system init file corruption and your build image will not boot! Run "sudo dpkg-reconfigure dash" and answer no when asked whether you want to install dash as /bin/sh.

Note 2: If you are using Ubuntu 8.04 or later you will also need to edit /etc/sysctl.conf and set 'vm.vdso_enabled = 0' and 'vm.mmap_min_addr = 0'. Afterwards run 'sudo sysctl -p'

If you get stuck I have a ready to run fedora vm on my website
Just unzip then run inside vmware player

Its fedora12 64 bit

unrar the vm somewhere
> then open it in vmware player (or vmware fusion on mac or import it into
> virtual box)
> fedora 12 x86_64
> setup with rpm fusion repo and livna
> chrome
> these were my install steps
> fedora 12 x86_64 (64bit)
> Base install with software development tools
> then
> sudo yum install yum-plugin-fastestmirror
> sudo yum groupinstall "Development Tools"
> sudo yum install vlc geany gstreamer-ffmpeg ffmpeg mplayer mplayer-gui
> gecko-mediaplayer mencoder \
> java-1.6.0-openjdk java-1.6.0-openjdk-plugin
> sudo yum install python m4 make wget curl ftp cvs subversion tar bzip2
> gzip unzip \
> python-psyco perl texinfo texi2html diffstat openjade docbook-style-dsssl
> \
> docbook-style-xsl docbook-dtds docbook-utils sed bison bc glibc-devel
> glibc-static \
> gcc binutils pcre pcre-devel git quilt groff linuxdoc-tools patch
> linuxdoc-tools \
> gcc-c++ help2man perl-ExtUtils-MakeMaker tcl-devel gettext ccache chrpath
> then installed the vmware tools
> video set to 800by600
> vm set to use 1 cpu with 2 cores and 1024MB ram
> change to the cpu type you have
> if you have plenty of ram increase to around half your physical ram.
> (very dodgy passwords)
> user
> abcdef123
> user is set as sudo
> root
> Gumstix

On 8/12/2010 2:54 PM, Darren wrote:
bitbake.conf is in /home/dhumphre/overo-oe/bitbake/conf/bitbake.conf

----- Original Message ----
From: Michael Poole <>
To: General mailing list for gumstix users. 
Sent: Tue, December 7, 2010 10:51:33 PM
Subject: Re: [Gumstix-users] Please help--I'm unable to get a build environment 

On Tue, Dec 7, 2010 at 10:33 PM, Darren <> wrote:
echo $BBPATH gives me:


I installed everything in /home/dhumphre/overo-oe
Is there a /home/dhumphre/overo-oe/build/
file (or a /home/dhumphre/overo-oe/build/conf/bitbake.conf or

bitbake will look for a "conf/bitbake.conf" file relative to each of
the paths in $BBPATH.  The error message suggests that it is missing.
To answer some of your other questions, I have used Ubuntu 10.04 and
10.10 to successfully build Overo images.  Unfortunately, diagnosing
errors can be a little bit difficult: they are usually specific, but
not always clear.

Michael Poole


What happens now with your Lotus Notes apps - do you make another costly 
upgrade, or settle for being marooned without product support? Time to move
off Lotus Notes and onto the cloud with, apps are easier to build,
use, and manage than apps on traditional platforms. Sign up for the Lotus 
Notes Migration Kit to learn more.
gumstix-users mailing list

UTS CRICOS Provider Code: 00099F
DISCLAIMER: This email message and any accompanying attachments may contain confidential information. If you are not the intended recipient, do not read, use, disseminate, distribute or copy this message or attachments. If you have received this message in error, please notify the sender immediately and delete this message. Any views expressed in this message are those of the individual sender, except where the sender expressly, and with authority, states them to be the views the University of Technology, Sydney. Before opening any attachments, please check them for viruses and defects.