I'll give this a try and report back.

Thanks,
-Scott

On Wed, Dec 24, 2008 at 10:40 PM, Grahame Jordan <gbj@theforce.com.au> wrote:
Hi,

I can confirm this.

apt-get install gcc-4.2 gcc-4.2-base gcc-4.2-locales

No need to uninstall gcc-4.3.

If required change the link to gcc via:
ls -l /usr/bin/gcc # This should be a link
sudo rm /usr/bin/gcc
sudo ln -s /usr/bin/gcc-4.2 /usr/bin/gcc

You may need to remove your ~/overo_oe/tmp directory as it was compiled
with gcc-4.3 and some api is probably non existent in gcc-4.2 and
something will fail.

Bitbake away

Good Luck

Grahame


Na'Tosha Bard wrote:
> Hello,
>
> I was able to continue development on my Ubuntu 8.10 installation by just installing an older version of gcc via apt from the Ubuntu repository and using that version of gcc for building OE.
>
> Best Regards,
> Na'Tosha
>
>
> -----Original Message-----
> From: Scott Harris [mailto:scottrharris@gmail.com]
> Sent: Mon 12/22/2008 5:39 PM
> To: General mailing list for gumstix users.
> Subject: [Gumstix-users] Ubuntu 8.10 and Open Embeded
>
> I've done some searching and it seems there is a problem with gcc4.3, Ubuntu
> 8.10, and OE.
>
> Does anyone know when a fix might be expected? Should I downgrade to Ubuntu
> 8.04, or just hang on for a while?
>
> Suggestions?
>
> Thanks,
> -Scott
>
>
> ------------------------------------------------------------------------
>
> ------------------------------------------------------------------------------
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> gumstix-users mailing list
> gumstix-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>


------------------------------------------------------------------------------
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users