I reverted back to revision 1183 and the audio I/O worked exactly as expected. I updated to the most recent buildroot revision (1219) and I again receive the error "/dev/dsp: Invalid". Any ideas what is causing this? Is there some setting I can change in the buildroot configuration so I can use the most recent buildroot revision but still get audio to work.

Thanks.

-RobB


On 12/23/06, Rob Barnes <robcb85@gmail.com> wrote:
I'm trying to get audio input and ouput working on the GPStix. I did modprobe on snd-pxa2xx-ac97, snd-pcm-oss, and snd-mixer-oss as instructed in the wiki. I'v also done a modprobe on a few other modules found in /lib/modules/2.6.18gum/kernel/sound/

When attempting to record or play back audio I get this:
                                        
# brec > foo                                                                   
brec: /dev/dsp: Invalid argument                                               
# bplay foo                                                                    
bplay: /dev/dsp: Invalid argument

/dev/dsp was automatically created when I did the modprobe.

What am I doing wrong?

Thanks.