I’ve got to the point where I set the GPRS to 1

 

I get back an IP

 

But after that

 

No matter what I send I donn’t get a “CONNECT’

 

 

Here is the reply from the ppp script:

 

Jan  1 00:00:43 gumstix-custom-verdex local2.info chat[707]: AT#SGACT=1,1,"user","pass"^M^M

Jan  1 00:00:43 gumstix-custom-verdex local2.info chat[707]: #SGACT: 10.160.7.238^M

Jan  1 00:00:43 gumstix-custom-verdex local2.info chat[707]: ^M

Jan  1 00:00:43 gumstix-custom-verdex local2.info chat[707]: OK

Jan  1 00:00:43 gumstix-custom-verdex local2.info chat[707]:  -- got it

Jan  1 00:00:43 gumstix-custom-verdex local2.info chat[707]: send (AT#SD=1,0,80,"www.google.com",0,0^M^M)

Jan  1 00:00:44 gumstix-custom-verdex local2.info chat[707]: expect (CONNECT)

Jan  1 00:00:44 gumstix-custom-verdex local2.info chat[707]: ^M

Jan  1 00:01:29 gumstix-custom-verdex local2.info chat[707]: alarm

Jan  1 00:01:29 gumstix-custom-verdex local2.info chat[707]: Failed

Jan  1 00:01:29 gumstix-custom-verdex daemon.err pppd[705]: Connect script failed

Jan  1 00:01:29 gumstix-custom-verdex daemon.info pppd[705]: Exit.

 

 

My 2 script are:

 

“PPP”

 

noipdefault

/dev/ttyS2

9600

connect 'chat -e -v -f /etc/ppp/gprs.chat'

defaultroute

usepeerdns

name user

debug

 

“CHAT”

 

'' AT

OK AT#SKTRST

OK AT+CGDCONT=1,"IP","cytamobile","0.0.0.0",0,0

OK AT#SCFG=1,1,0,90,600,50

OK AT#SGACT=1,1,"user","pass"

OK AT#SD=1,0,80,"www.google.com",0,0

CONNECT ''

 

 

PLEASE help out here

What could be the problem?