You might try toggling


In userspace, after boot. In a similar splice situation, toggling 168 solved a similar problem for me.
I think at boot there's some timing problem related to the power.


From: Mark Stamer <>
To: General mailing list for gumstix users. <>
Sent: Tuesday, January 29, 2013 8:29 AM
Subject: Re: [Gumstix-users] Alternative OTG USB power

Hello Alexander,

I'm trying to get a webcam to work the same way you did it. I spliced a USB cable and connected the power lines to a 5 V source. However, when I connect the camera there is no handshaking taking place anymore. The data lines are intact and the power lines going to the gumstix are dead ends. Could that be the problem? Do you have any idea why this is and what I could do with the dead ends to fake a connection if that's what's missing for the handshaking?

Thanks a lot in advance. 

Dipl.-Ing. Mark Stamer
Technische Universität Hamburg-Harburg
Institut für Mikrosystemtechnik (E-7)
Eißendorfer Str. 42
21073 Hamburg

Tel.: +49 (0)40 42878 2402
Fax: +49 (0)40 42878 2396

On Feb 28, 2012, at 10:51 AM, Alexander Thomas <> wrote:

On Mon, Feb 27, 2012 at 5:51 PM, Lark, Nathaniel (SELEX GALILEO, UK)
<> wrote:
We are attempting to remotely power a USB device by splicing into the gnd and 5V power lines and providing an alternative supply from that provided by the Overo OTG USB port.

This issue surrounding how the USB device presents itself and why the device will still be rejected even though it is externally powered is understood by us.  What we cant do is find a solution to bypassing the power check all together.  The archives suggest some approaches and code changes to the kernel back in 2010, however a search of our kernel source code (3.0.0.) suggest this may not be relevant any longer.

Chris cotton provided this solution in an earlier discussion, May 10, 2010, however we could find no such code to make the change.

Any help would be most appreciated  :)

I had this exact same problem and found a solution for more recent
kernels. After plugging in the device, run the following command:
echo -n 1 > /sys/devices/platform/musb_hdrc/usb1/1-1/bConfigurationValue
This disables the power limit enforcing. You may still get a warning
in the system log, but the device should work.
This has to be repeated every time the Overo is rebooted or the device
is plugged in.

Of course you should never run this command when a device that can
draw more than 100mA is connected to the OTG port with a non-spliced

Alexander Thomas
Research Engineer

T +32 16 40 12 82
M +32 477 51 63 62

Keep Your Developer Skills Current with LearnDevNow!
The most comprehensive online learning library for Microsoft developers
is just $99.99! Visual Studio, SharePoint, SQL - plus HTML5, CSS3, MVC3,
Metro Style Apps, more. Free future releases when you subscribe now!
gumstix-users mailing list

Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
MVPs and experts. ON SALE this month only -- learn more at:
gumstix-users mailing list