What happens when you connect a powered USB hub that supports high-speed mode into the host port, then plug your QuickCam into the hub?

If that doesn't work, what about plugging other USB devices into the hub, e.g. keyboard and mouse?

Greg




From: kfcandroid <kfc.android@gmail.com>
To: gumstix-users@lists.sourceforge.net
Sent: Monday, October 29, 2012 3:58 PM
Subject: Re: [Gumstix-users] Streaming webcam with Gumstix Overo Fire

Guys,

I had a bad feeling about the USB HOST port on my Chestnut43 board, let me
explain why:

First, I tried to re-compile the kernel with UVC video camera driver
followed by Derek's instruction in
other post. (see
http://gumstix.8.n6.nabble.com/How-can-I-get-quot-developer-image-quot-kernel-source-code-td4965579.html#a4965636)

Second, I compiled modules:
make ARCH=arm CROSS_COMPILE=arm-linux-gnueabi- modules -j4

And then install those modules:
sudo INSTALL_MOD_PATH=/media/rootfs make ARCH=arm
CROSS_COMPILE=arm-linux-gnueabi- modules_install

On Gumstix, I typed:
root@overo:~# depmod
(nothing seem to happen)

Next, I connect the Logitech QuickCam Express (which was supported by
qc-driver project)
and I type:
root@overo:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@overo:~#

No device detected... I tried to reboot, or plug in a USB Mouse, or Flash
Drive
but I still got nothing by typing 'lsusb'
(Besides, the Flash drive has a light which will be on once plugged into PC
USB port, but it never on the HOST port)

So, I start thinking *maybe the Chestnut43 board has a faulty USB HOST
port*?

Googled that, and I found the following threads :
http://gumstix.8.n6.nabble.com/Overo-Chestnut-USB-ports-td4370132.html
http://gumstix.8.n6.nabble.com/USB-Host-problems-td662510.html
http://neostix.com/hardware-design/product-changes-known-issues-a-eol/67-known-issues.html

*Is there anyway I can justify whether I have a faulty USB port or not?*

USB Webcam project is very important since its my school project, but looks
like I have to solve the
USB port issue first.

Any idea about this situation? Thanks in advance.

James



--
View this message in context: http://gumstix.8.n6.nabble.com/Streaming-webcam-with-Gumstix-Overo-Fire-tp561852p4965839.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
The Windows 8 Center - In partnership with Sourceforge
Your idea - your app - 30 days.
Get started!
http://windows8center.sourceforge.net/
what-html-developers-need-to-know-about-coding-windows-8-metro-style-apps/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users