I had submitted the boot log to the list; however, it is still awaiting approval due to its length.

As an update, I enabled the DEBUG_LL and EARLY_PRINTK in the config to get a more detailed log after the hang/dump. Here is what I get:

HS USB OTG: no transceiver configured
musb_hdrc: musb_init_controller failed with status -19
Unable to handle kernel NULL pointer dereference at virtual address 00000028
[...]
It prints a stack trace, then reports a kernel panic. (Kernel panic - not syncing:Attempted to kill init!)

I've tracked down this error to the musb_core.c (http://lxr.free-electrons.com/source/drivers/usb/musb/musb_core.c?v=2.6.29;a=arm#L1937) and omap2430.c files (http://lxr.free-electrons.com/source/drivers/usb/musb/omap2430.c?v=2.6.33;a=arm#L203) (the latter is the clock(?) that the Overo Fire uses, I imagine?), and it looks like it needs some sort of external transceiver? Oddly enough, the error I am seeing is not defined for the 2.6.29 kernel. I only found it in the kernels >=2.6.33.

Does this information point to any specific problem I should address?

Thanks.


From: Adam Lee <adam.yh.lee@gmail.com>
To: Nerd Cube <nerdcube314@yahoo.com>; General mailing list for gumstix users. <gumstix-users@lists.sourceforge.net>
Sent: Monday, July 16, 2012 3:24 AM
Subject: Re: [Gumstix-users] Built images not booting on Gumstix (Boot hangs at "Uncompressing linux...")

Sorry it's not much of a help, but can you share the boot log? And perhaps even the rootfs and the uImage? I will give it a try on my Overo.

On Sun, Jul 15, 2012 at 9:19 PM, Nerd Cube <nerdcube314@yahoo.com> wrote:
Hi,

Thanks for your quick response!
Yes, every time I save to the SD card and try to boot I do a "nand erase 240000 20000" and reset. I still get stuck at the decompression stage.

Are there other details in particular that would be beneficial for me to report to diagnose this issue?

Thanks!


From: acsmith <acsmith@stanford.edu>
To: gumstix-users@lists.sourceforge.net
Sent: Sunday, July 15, 2012 9:11 PM
Subject: Re: [Gumstix-users] Built images not booting on Gumstix (Boot hangs at "Uncompressing linux...")

Hi,

When you created your SD card, did you follow these directions (
http://gumstix.org/create-a-bootable-microsd-card.html Make SD Card )?
Specifically, did you follow the sections at the bottom (/U-boot Environment
Refresh/)?  I know I ran into a similar problem that was solely due to a new
u-boot image that needed to have the environment variables cleared (good
thing to do with any new u-boot image).  If you haven't cleared the
environment variables it's a good place to start.  Report back with more
details if you still have problems.

Good luck,

Andrew

--
View this message in context: http://gumstix.8.n6.nabble.com/Built-images-not-booting-on-Gumstix-Boot-hangs-at-Uncompressing-linux-tp4964911p4964913.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users



------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users