What version of buildroot are you running? You can check it by running "# more /etc/gumstix-release".

I recommend that you use 1566. It should work for RFCOMM without any configuration modifications.

- Mark

----- Original Message ----
From: Mark Ahlenius <>
To: General mailing list for gumstix users. <>
Sent: Tuesday, December 11, 2007 9:17:21 PM
Subject: Re: [Gumstix-users] Bluetooth services problem- help please


I am once again having some BT problems.  I thought this was voltage
related, but it may not be.

When I boot up, I can see my gumstix from my PC but cannot connect to it
using the a BT serial port device (this worked in the past).

When I run the "sdptool browse local" command which Mark Young suggested
below, I do not get a "RFCOMM" in the Protocol Descriptor List - BUT I
do see several RFCOMM processes when I do a "ps"

Should I see this descriptor running in a sdptool output?

If its not running, what could be the cause?



Mark Young wrote:
> Try "sdptool browse local" from your gumstix prompt and see if your
> rfcomm service is running. You should see something like this -
> Browsing FF:FF:FF:00:00:00 ...
> Service Name: Serial Port
> Service Description: COM Port
> Service RecHandle: 0x10000
> Service Class ID List:
>  "Serial Port" (0x1101)
> Protocol Descriptor List:
>  "L2CAP" (0x0100)
>  "RFCOMM" (0x0003)
>    Channel: 1
> Language Base Attr List:
>  code_ISO639: 0x656e
>  encoding:    0x6a
>  base_offset: 0x100
> Profile Descriptor List:
>  "Serial Port" (0x1101)
>    Version: 0x0100
> If that checks out, make sure you're providing the correct pin when
> you "add" your Gumstix on the Windows side (I'm assuming its a Windows
> PC).

SF.Net email is sponsored by:
Check out the new Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
gumstix-users mailing list

Looking for last minute shopping deals? Find them fast with Yahoo! Search.