To give you guys my current situation, I have been able to communicate between the gumstix and robostix just fine and have been able to change the fuse settings and load hex files from the gumstix (using uisp).  Everything was working fine and I was able to load the flash-led.hex file and that worked great. 

       
The main goal of working with the robostix for me is to get it to interface with an OV6620 cmos camera and have it do color blob detection.  So in order to write the software to do that, I decided developing that software would be much easier using a standalone ISP programmer (the STK500) and AVRStudio 4.  After switching to this setup, I was able to load .hex files fine, as well as even compile my own test C code and load the resulting .hex file.

The problem I have right now though, is that somewhere along the line, everything stopped working properly.  Now, even when I load the Flash-LED.hex file, it isn't flashing the LEDs correctly.  I have no idea what went wrong.  I went back to hooking it up to the gumstix, and tried resetting the fuses again and reloading the .hex file, and the LEDs still aren't lighting up the way they are supposed (if they even light up at all, it seems rather sporadic).  If this is happening now, do you think I fried the atmega128 somewhere along the line?  I'm new to developing with the atmega128, but I do have experience with other micro controllers.  I can't figure out what I possibly could have done to get the robostix to not function correctly.  Also, I never had the ISP hooked up to the robostix at the same time the gumstix was plugged intot he robostix.

If you have any advice you can give me as far as trouble shooting this problem I would much appreciate it.

Thank you,
Dan