Thanks to all who have been SO helpful so far !

 

I started over with a fresh ext3 partition:

I did notice one odd thing. Why does everything come from ? /www.gumstix.net/feeds/unstable/ ...

Should upgrade and update not download from a ‘stable’ feed rather than ‘unstable’ ?

 

1)    Used "sudo mkfs.ext3 /dev/sdb2" to wipe the ext3 partition and start over.

 

2)    Un-tared the root file system into the ext3 partition

 

      bill@GnuRadio:~/Temp$ sudo mount /dev/sdb2 /media

      bill@GnuRadio:~/Temp$ cd /media/

      bill@GnuRadio:/media$

 

      sudo tar xvjf ~/Temp/console-image.rootfs.tar.bz2

 

3)    When I tried to un-mount /dev/sdb2 I got the following error:

     

      bill@GnuRadio:/media$ sudo umount /dev/sdb2

      umount: /media: device is busy.

        (In some cases useful info about processes that use the device is found by lsof(8) or fuser(1))

 

4)    I closed the terminal window and opened another. The command completed successfully.

      When I removed and re-inserted the Micro-SD holder, Ubuntu saw and displayed both the FAT and ext3 partitions.

 

5)    $ opkg update

 

Collected errors:

* opkg_download: Failed to download http://www.gumstix.net/feeds/unstable/ipk/glibc/armv7a/debug/Packages.gz, wget returned 1.

 

 

      $ opkg upgrade

 

Configuring kernel-module-ipv6.

FATAL: Could not open '/lib/modules/2.6.34/kernel/net/ipv6/ipv6.ko': No such file or directory

 

//usr/lib/opkg/info/hicolor-icon-theme.postinst: line 7: can't create /etc/gtk-2.0/gdk-pixbuf.loaders: nonexistent directory

//usr/lib/opkg/info/hicolor-icon-theme.postinst: line 7: gdk-pixbuf-query-loaders: not found

//usr/lib/opkg/info/hicolor-icon-theme.postinst: line 13: gtk-update-icon-cache: not found

Configuring dhcp-client.

 

Collected errors:

 * pkg_run_script: package "hicolor-icon-theme" postinst script returned status 127.

 * opkg_configure: hicolor-icon-theme.postinst returned 127.

 

6)    $opkg install task-native-sdk

.

.

.

Configuring perl-modules.

Configuring libgmp10.

Configuring libmpfr4.

Configuring cpp.

Configuring cpp-symlinks.

Configuring g++.

Configuring g++-symlinks.

Configuring make.

Collected errors:

 * check_data_file_clashes: Package libpanelw5 wants to install file /usr/lib/libpanelw.so.5.7

      But that file is already provided by package  * libpanelw

 * check_data_file_clashes: Package libpanelw5 wants to install file /usr/lib/libpanelw.so.5

      But that file is already provided by package  * libpanelw

 * opkg_install_cmd: Cannot install package task-native-sdk.

 * pkg_run_script: package "hicolor-icon-theme" postinst script returned status 127.

 * opkg_configure: hicolor-icon-theme.postinst returned 127.

 

 

 Thanks for reading all this stuff J

 

Bill

 

 

"People sleep peaceably in their beds at night only because rough men

stand ready to do violence on their behalf." - George Orwell