Well I swapped com boards, by putting the suspect Earth board on my development system (working) Tobi board,

with the Gnome image uSD card also from the working Development system.

It worked perfectly.


Then I put the uSD card with the console image into the Earth and it also worked perfectly.

See below:


Texas Instruments X-Loader 1.4.4ss (Oct 20 2010 - 10:10:28)

OMAP3503-GP ES3.1

Board revision: 2

Reading boot sector

Loading u-boot.bin from mmc



U-Boot 2010.09 (Oct 20 2010 - 10:11:49)


OMAP3503-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 600 mHz

Gumstix Overo board + LPDDR/NAND

I2C:   ready

DRAM:  512 MiB

NAND:  512 MiB

*** Warning - bad CRC or NAND, using default environment


In:    serial

Out:   serial

Err:   serial

Board revision: 2

Direct connection on mmc2

No EEPROM on expansion board

Die ID #18e400040000000004037d0710020008

Net:   smc911x-0

Hit any key to stop autoboot:  0

mmc1 is available


So it looks like Gumstix is some kind of problems with their Tobi boards L


Over to you Guys J




A prisoner of war is a man who tries to kill you and fails, and then asks you not to kill him.

Winston Churchill