Looks like the same problem I had with my original netwifisd, if the default images don’t work and you’ve tried to ping an ip from the uboot menu and you get nothing, contact sales@gumstix.com for an RMA.

 

Regards,

Drew

 

From: gumstix-users-bounces@lists.sourceforge.net [mailto:gumstix-users-bounces@lists.sourceforge.net] On Behalf Of John Alfredo
Sent: 07 July 2008 18:24
To: Gumstix-Users
Subject: [Gumstix-users] eth0 half-duplex problem

 

Hi all,

 

I’ve got a new XM4-bt + netmicroSD + consoleLCD16 + SAMSUNG and can’t get eth0 to work.  Looking at the boot messages I see that eth0 always comes up as half-duplex

 

eth0: link up, 100Mbps, half-duplex, lpa 0x0080

 

I’m thinking this should come up as full-duplex.

 

Also, I have a static IP configured and have tested the cable on another machine.  When I try to ping the DSL (10.0.0.2) I see the activity lights on both the netmicroSD and the DSL blinking at regular intervals at the same time, the TX/RX packet count increments on the DSL, however ping hangs.  Also, I have the port on the DSL configured as 100/Full rather than the default “Autonego” since when I invoke

 

“/etc/init.d/networking start”        it reports           “Auto negotiation NOT supported.”  This didn’t help however.

 

Here’s what my /etc/network/interfaces looks like followed by the boot messages.  Any help would be sincerely appreciated.

 

auto lo

iface lo inet loopback

 

auto eth0

iface eth0 inet static

address 10.0.0.109

netmask 255.255.255.0

broadcast 10.0.0.255

network 10.0.0.0

gateway 10.0.0.2

 

# Bluetooth networking

iface bnep0 inet dhcp

 

Everything else in interfaces is commented out.  Here’s what ifconfig looks like.  TX shows 21 packets as a result of ping:

 

root@gumstix-custom-verdex:~$ ifconfig

eth0      Link encap:Ethernet  HWaddr AE:1A:88:56:58:90

          inet addr:10.0.0.109  Bcast:10.0.0.255  Mask:255.255.255.0

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 B)  TX bytes:3861 (3.7 KiB)

          Interrupt:131 DMA chan:ff

 

lo        Link encap:Local Loopback

          inet addr:127.0.0.1  Mask:255.0.0.0

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:48 errors:0 dropped:0 overruns:0 frame:0

          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:3972 (3.8 KiB)  TX bytes:3972 (3.8 KiB)

 

U-Boot 1.2.0 (Dec 21 2007 - 13:34:50) - PXA270@400 MHz - 1578M

 

*** Welcome to Gumstix ***

 

DRAM:  64 MB

Flash: 16 MB

Using default environment

 

Hit any key to stop autoboot:  0

Instruction Cache is ON

Copying kernel to 0xa2000000 from 0x00f00000 (length 0x00100000)...done

## Booting image at a2000000 ...

   Image Name:   Angstrom/2.6.21/gumstix-custom-v

   Image Type:   ARM Linux Kernel Image (uncompressed)

   Data Size:    1028168 Bytes = 1004.1 kB

   Load Address: a0008000

   Entry Point:  a0008000

OK

 

Starting kernel ...

 

Linux version 2.6.21 (otto@otto) (gcc version 4.1.2) #1 Wed Apr 2 01:00:42 PDT 2008

CPU: XScale-PXA270 [69054117] revision 7 (ARMv5TE), cr=0000397f

Machine: The Gumstix Platform

Memory policy: ECC disabled, Data cache writeback

Run Mode clock: 208.00MHz (*16)

Turbo Mode clock: 416.00MHz (*2.0, active)

Memory clock: 104.00MHz (/2)

System bus clock: 104.00MHz

CPU0: D VIVT undefined 5 cache

CPU0: I cache: 32768 bytes, associativity 32, 32 byte lines, 32 sets

CPU0: D cache: 32768 bytes, associativity 32, 32 byte lines, 32 sets

Built 1 zonelists.  Total pages: 16256

Kernel command line: console=ttyS0,115200n8 root=1f01 rootfstype=jffs2 reboot=cold,hard

PID hash table entries: 256 (order: 8, 1024 bytes)

Console: colour dummy device 80x30

Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)

Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)

Memory: 64MB = 64MB total

Memory: 62720KB available (1804K code, 196K data, 148K init)

Mount-cache hash table entries: 512

CPU: Testing write buffer coherency: ok

NET: Registered protocol family 16

NET: Registered protocol family 2

Time: pxa_timer clocksource has been installed.

IP route cache hash table entries: 1024 (order: 0, 4096 bytes)

TCP established hash table entries: 2048 (order: 2, 16384 bytes)

TCP bind hash table entries: 2048 (order: 1, 8192 bytes)

TCP: Hash tables configured (established 2048 bind 2048)

TCP reno registered

JFFS2 version 2.2. (NAND) (SUMMARY)  (C) 2001-2006 Red Hat, Inc.

io scheduler noop registered

io scheduler cfq registered (default)

Console: switching to colour frame buffer device 80x24

pxa2xx-uart.0: ttyS0 at MMIO 0x40100000 (irq = 22) is a FFUART

pxa2xx-uart.1: ttyS1 at MMIO 0x40200000 (irq = 21) is a BTUART

pxa2xx-uart.2: ttyS2 at MMIO 0x40700000 (irq = 20) is a STUART

Probing Gumstix Flash ROM at physical address 0x00000000 (16-bit bankwidth)

Gumstix Flash ROM: Found 1 x16 devices at 0x0 in 16-bit bank

 Intel/Sharp Extended Query Table at 0x010A

 Intel/Sharp Extended Query Table at 0x010A

 Intel/Sharp Extended Query Table at 0x010A

 Intel/Sharp Extended Query Table at 0x010A

 Intel/Sharp Extended Query Table at 0x010A

Using buffer write method

cfi_cmdset_0001: Erase suspend on write enabled

Using static partitions on Gumstix Flash ROM

Creating 3 MTD partitions on "Gumstix Flash ROM":

0x00000000-0x00040000 : "Bootloader"

0x00040000-0x00f00000 : "RootFS"

0x00f00000-0x01000000 : "Kernel"

TCP cubic registered

NET: Registered protocol family 1

NET: Registered protocol family 17

XScale iWMMXt coprocessor detected.

VFS: Mounted root (jffs2 filesystem).

Freeing init memory: 148K

INIT: version 2.86 booting

Starting the hotplug events dispatcher udevd

Synthesizing the initial hotplug events

Remounting root file system...

gumstix_smc91x_init: smc91x chip not found, returning -ENXIO

smc91x: Unknown symbol gumstix_smc91x_load

eth0: LAN9117 (rev 2) at 0xc4870000 IRQ 131

eth0: Ethernet addr: ae:1a:88:56:58:90

Bluetooth: Core ver 2.11

NET: Registered protocol family 31

Bluetooth: HCI device and connection manager initialized

Bluetooth: HCI socket layer initialized

Bluetooth: L2CAP ver 2.8

Bluetooth: L2CAP socket layer initialized

Bluetooth: HIDP (Human Interface Emulation) ver 1.2

usbcore: registered new interface driver usbfs

usbcore: registered new interface driver hub

usbcore: registered new device driver usb

pxa27x-ohci pxa27x-ohci: PXA27x OHCI

pxa27x-ohci pxa27x-ohci: new USB bus registered, assigned bus number 1

pxa27x-ohci pxa27x-ohci: irq 3, io mem 0x4c000000

usb usb1: configuration #1 chosen from 1 choice

hub 1-0:1.0: USB hub found

hub 1-0:1.0: 3 ports detected

Not netCF-vx board: using newer GPIO configuration

CPLD responded with: ff

Bluetooth: RFCOMM socket layer initialized

Bluetooth: RFCOMM TTY layer initialized

Bluetooth: RFCOMM ver 1.8

root: mount: special device /dev/hda1 does not exist

root: mount: special device /dev/mmcblk0p1 does not exist

root: mount: special device /dev/sda1 does not exist

Setting up IP spoofing protection: rp_filter.

Configuring network interfaces... eth0: link down

eth0      no wireless extensions.

 

udhcpc (v1.2.1) started

udhcpc[574]: udhcpc (v1.2.1) started

Sending discover...

udhcpc[574]: Sending discover...

eth0: link up, 100Mbps, half-duplex, lpa 0x0080

Sending discover...

udhcpc[574]: Sending discover...

Sending discover...

udhcpc[574]: Sending discover...

No lease, failing.

udhcpc[574]: No lease, failing.

cfio: module license 'unspecified' taints kernel.

Before register driver

After register driver

Error for wireless request "Set ESSID" (8B1A) :

    SET failed on device wlan0 ; No such device.

Error for wireless request "Set Mode" (8B06) :

    SET failed on device wlan0 ; No such device.

SIOCGIFFLAGS: No such device

wlan0     No such device

 

udhcpc (v1.2.1) started

udhcpc[617]: udhcpc (v1.2.1) started

SIOCGIFINDEX failed!: No such device

udhcpc[617]: SIOCGIFINDEX failed!: No such device

done.

Nothing to be done

INIT: Entering runlevel: 5

Starting Dropbear SSH server: dropbear.

Starting HTTP server: boagethostbyname:: Resource temporarily unavailable

Starting system message bus: dbus.

Starting ntpd: done

Starting syslogd/klogd: done

Starting 32kHz clock...Settled

Starting Bluetooth subsystem:

Trying baud rate 921600...

No response after reset

Got Startup Event -- retrying once

Detected bluetooth module at 921600 baud

Got: status=0x00, hci_ver=0x03, hci_rev=0x62b9, lmp_ver=0x03, manuf=0x0009, lmp_subver=0x62b9

Bluetooth: HCI UART driver ver 2.2

Bluetooth: HCI H4 protocol initialized

 ttyS1 hcid hid2hciWaiting for connection on channel 1

 rfcomm hidd.

ALSA: loading sound modules...

ASoC version 0.13.0

AC97 SoC Audio Codec 0.6

asoc: AC97 HiFi <-> pxa2xx-ac97 mapping ok

pxa2xx_ac97_cold_reset: cold reset timeout (GSR=0x0)

pxa2xx_ac97_read: read error (ac97_reg=7c GSR=0x444)

pxa2xx_ac97_read: read error (ac97_reg=7e GSR=0x444)

AC'97 0 access is not valid [0xffffffff], removing mixer.

soc-audio: probe of soc-audio failed with error -5

ALSA: Restoring mixer settings...

/usr/sbin/alsactl: load_state:1329: No soundcards found...

Running ntpdate to synchronize clockError : Temporary failure in name resolution

.

Starting bonjour:

Starting Vixie-cron.

Starting i2c...

tsc2003 i2c touch screen controller

i2c: error: timeout

i2c: msg_num: 1 msg_idx: 0 msg_ptr: 0

i2c: ICR: 000007e9 ISR: 00000004

i2c: log:

tsc2003_i2c_detect: probing address 0x48

i2c_adapter i2c-0: i2c_pxa: timeout waiting for bus free

i2c_adapter i2c-0: i2c_pxa: timeout waiting for bus free

i2c_adapter i2c-0: i2c_pxa: timeout waiting for bus free

i2c_adapter i2c-0: i2c_pxa: timeout waiting for bus free

i2c_adapter i2c-0: i2c_pxa: timeout waiting for bus free

i2c_adapter i2c-0: i2c_pxa: timeout waiting for bus free

i2c: error: exhausted retries

i2c: msg_num: 1 msg_idx: 0 msg_ptr: 0

i2c: ICR: 000007e9 ISR: 00000004

i2c: log:

I2C: i2c-0: PXA I2C adapter

tsc2003 i2c touch screen controller

tsc2003_i2c_detect: probing address 0x48

i2c: error: timeout

i2c: msg_num: 1 msg_idx: 0 msg_ptr: 1

i2c: ICR: 000017ee ISR: 00000005

i2c: log: [00000045:000017e8] [00000085:000017ee]

I2C: i2c-1: PXA I2C adapter

i2c /dev entries driver

 

OpenEmbedded Linux gumstix-custom-verdex ttyS0

 

Angstrom 2007.9-test-20080402 gumstix-custom-verdex ttyS0

 

gumstix-custom-verdex login: root

Password:

 

Welcome to gumstix!

For information on how to customize or update this software please visit:

http://www.gumstix.net

 

 

Thanks in advance,

 

John Alfredo