Ok Here's what I did.  Beyond staying uo too late last night,  I might have screwed tings up.
I have a Verdex XL6P  with uBoot version 1.1.4.  I looked at the page http://docwiki.gumstix.org/Replacing_the_filesystem_image.  This is where being up too late comes in.  I followed the instructions for the basix and connex:
GUM> loadb a2000000
then sent the file via kermit
GUM> protect on 1:0-1
GUM> erase all
Then I realized I was in the wrong section so I tried the following:
GUM>pro on 1:0-1 && jera all & cp.b a2000000 40000 ${filesize}
but nothing happened, so then I tried
GUM>cp.b a2000000 40000 ${filesize}
and the file system copied.  Then I copied the uImage
GUM> loadb a2000000
then sent the file via kermit
then tried >GUM katinstall 10000
I got  unknonwn command 'katinstall',
Of course then I realized that that was for uBoot 1.2.0 and I had 1.1.4
Ok so thats where I am.  What do I do?  It looks like the I have to log into linux to copy files but Ialready killed the rootfs.  I have no idea what to do.
I really could use some help to get out of this mess.