I did that and it worked.  

Just a guess:  did you “chmod a+x S60usbnet-setip”?

 

Jiefei Ma

 

-----Original Message-----
From: gumstix-users-bounces@lists.sourceforge.net [mailto:gumstix-users-bounces@lists.sourceforge.net] On Behalf Of jaiswal.vikash@wipro.com
Sent: 02 January 2007 13:34
To: gumstix-users@lists.sourceforge.net
Subject: [Gumstix-users] Connection gumstix to linux host using usb

 

Hi ,

 

I've been trying to connect my gumstix board to my linux( fedora core 2 with kernel 2.6.19 ) host using usb .

 

While searching in the net I came across a page( Link :  http://iarc1.ece.utexas.edu/wikicup/index.php/Gumstix ) mentioning the steps , I followed those steps but it is giving the error

        port 22 : no route to host .

 

The step which I performed are as: 

 

 I created a file in /etc/init.d called "S60usbnet-setip". This file had the following content :

 #!/bin/sh
 echo "Setting up usbnet IP as 192.168.1.2"
 ifconfig usb0 192.168.1.2
 exit 0

 

This shall assign the gumstix the ip 192.168.1.2 over usbnet AT STARTUP. I rebooted the system( host linux ) .
Now, on your host linux machine ( which was be connected to the gumstix over usb) , I executed the command

   

    ifconfig usb0 192.168.1.1

 

I now tried to login to the gumstix by using the command :
    ssh root@192.168.1.2

 

At this point I got the error :

    port 22: no rout to host

 

Could anyone suggest where I'm going wrong .

Any suggestions in this regard will be appreciated . 

 

Regards ,

Vikash