#15 Overo just does not boot

open
nobody
None
5
2010-10-21
2010-10-21
Kaz
No

My overo and Chestnut43 arrived on a few days ago, and when I set it up the first time, connected to kermit, etc etc, nothing happened.. To me that meant there was no bootable system.. so I removed the micro SD card, and put it into my computer, used the tutorial on how to load the SD card with linux, and then put it back, and tried to boot again, and it had a couple of errors.. After sorting them out, I tried again, and it kept on rebooting again, for 12 hours, and in the end, I thought it was because I was using the omap3.desktop image, which was too large.. (btw, all the images I have used are off the gumstix.net website - pre-built ones). So I reformated the card, and loaded it with the console image, and for the past couple of hours all it is doing is:

�tصb�$U
@ @ @D��` @ @

Texas Instruments X-Loader 1.4.2 (Jan 1 2010 - 10:18:38)
Reading boot sector
Loading u-boot.bin from mmc

U-Boot 2009.11 (Jan 01 2010 - 10:32:50)

OMAP3530-GP ES3.1, CPU-OPP2 L3-165MHz
Gumstix Overo board + LPDDR/NAND
I2C: ready
DRAM: 256 MB
NAND: 256 MiB
In: serial
Out: serial
Err: serial
Die ID #043400040000000004037f680e01a015
Net: smc911x-0
Hit any key to stop autoboot: 0
mmc1 is available
reading boot.scr

** Unable to read "boot.scr" from mmc 0:1 **
reading uImage
�tصb�$U
@ � �D��` @ @

Texas Instruments X-Loader 1.4.2 (Jan 1 2010 - 10:18:38)
Reading boot sector
Loading u-boot.bin from mmc

U-Boot 2009.11 (Jan 01 2010 - 10:32:50)

OMAP3530-GP ES3.1, CPU-OPP2 L3-165MHz
Gumstix Overo board + LPDDR/NAND
I2C: ready
DRAM: 256 MB
NAND: 256 MiB
In: serial
Out: serial
Err: serial
Die ID #043400040000000004037f680e01a015
Net: smc911x-0
Hit any key to stop autoboot: 0
mmc1 is available
reading boot.scr

** Unable to read "boot.scr" from mmc 0:1 **
reading uImage
�tصb�$U
@ @ @D��` @ @

Texas Instruments X-Loader 1.4.2 (Jan 1 2010 - 10:18:38)
Reading boot sector
Loading u-boot.bin from mmc

U-Boot 2009.11 (Jan 01 2010 - 10:32:50)

OMAP3530-GP ES3.1, CPU-OPP2 L3-165MHz
Gumstix Overo board + LPDDR/NAND
I2C: ready
DRAM: 256 MB
NAND: 256 MiB
In: serial
Out: serial
Err: serial
Die ID #043400040000000004037f680e01a015
Net: smc911x-0
Hit any key to stop autoboot: 0
mmc1 is available
reading boot.scr

** Unable to read "boot.scr" from mmc 0:1 **
reading uImage
�tصb�$U
@ @ @D��` @ @

And it does this again and again and again...

I dont know what to do..is that normal? I have read that it takes a long time, but because it has not budged from these messages for the past couple of hours, I'm starting to wonder again if its doing anything.

P.S - I have partitioned it as the tutorial suggested, and used the u-boot.bin, uImage and MLO file that were in the same folder as the omap3.console image on the gumstix website.

Am I doing anything wrong?

Please help, this is for my phd and its holding everything up.

Thanks,
Kaz

Discussion

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks