YouTube Files

  • Wagg

    Wagg - 2009-04-29

    In the past, I could add an .flv extension to YouTube files in my Firefox cache and play them with MPC.  Recently, that stopped working and I get a "Media Type 0: Unknown" error.

    Anybody know what's up with that?  Any way to continue storing and playing YouTube files locally?

    • Tim

      Tim - 2009-04-30

      The higher quality videos are .MP4 files, so try that extension.

      • Wagg

        Wagg - 2009-04-30

        Tried that.  Here's a sample video that doesn't work as either .flv or as .mp4 for HQ

        Typically, the Firefox cache is located at

        C:\Documents and Settings\[UserAccount]\Local Settings\Application Data\Mozilla\Firefox\Profiles\[code#].default\Cache

        Both the lower quality and HQ files display in MPC with the "Media Type 0: Unknown" error.

        • Stuart Halliday

          Stuart Halliday - 2009-04-30

          I downloaded this video off YouTube as a .mp4 and it plays 100% in MPC.

          video is 25,330,243 bytes long

          MPC says it is :

          Video: MPEG4 Video (H264) 480x360 25.00fps [Video]
          Audio: AAC 44100Hz stereo 1411Kbps [Audio]

          Gspot says it is:

          mp42: MP4 v2 [ISO 14496-14]
          - isom: MP4  Base Media v1 [IS0 14496-12:2003]
          - avc1: MP4 Base w/ AVC ext [ISO 14496-12:2005]
          Recommended Display Size: 480 x 360
          Created:     2009 Apr 19   20:39:03
          Modified:     2009 Apr 19   20:39:03

          I'm using MPC (revision 91) on Windows XP pro SP3.

          Why not try MPC with the K-Lite package?

          I used

          and replace MPC with the more up to date version? This 'guliverkli' is no longer the most up to date version.


          and get the latest. :-)

        • Tim

          Tim - 2009-05-01

          I downloaded it in both FLV and MP4 formats and they both use the h264 (x264) codec I have installed.  The audio is AAC, but MPC handles that internally.

  • Wagg

    Wagg - 2009-09-13

    Sorry for the delay in responding-the summer got away from me.

    The info suggested was all very good, and solved the problem.  My installation of MPC went back to 2007 and could play h263 files, but not h264.  Upgraded as recommended and no further problems.



Log in to post a comment.