"Failed to render the file" with MMS

  • synkdorbit

    synkdorbit - 2007-07-16

    Hello all,

    I am able to open virtually every file and stream I want without problem, EXCEPT for MMS streams. Without hesitation, any stream that has an MMS URL instantly fails with that dreaded message, "Failed to render the file".

    I've tried several solutions to no avail. On this forum and a few others, there have been suggestions to install different codec packs, which I've tried, and no luck. I've been at this for about a week.

    MMS streams work just fine using WMP, and it seems that the MPC installation on my laptop has no trouble playing them either. Usually what I have to do in order to get these streams to play is to change the mms:// URL to http:// and then it will play fine. Needless to say, it's pretty annoying.

    I am at my wit's end with this, and I can't stand the fact that I can't get this working. I'd appreciate whatever help anyone might be able to provide. Any ideas?

    • Wagg

      Wagg - 2007-07-17

      Well, there are a lot of people here who do not agree with me (there are some who do, though), but I took another poster's advice and installed the K-Lite Mega Codec Pack


      Someone had installed iTunes on one of my PC's, and NOTHING worked after that.  The K-Lite Mega Pack fixed it, and everything I need plays, including most streams.  The folks maintaining that Pack are not beginners--they do very good work.

      Note, however, that a lot of streamers are purposely making it harder and harder to find out the real true address of their streams.  It may be an example when you find the need to switch from "mms" to "http".

      MPC keeps getting progressively better at playing streams, but I must admit that I got used to using XMPlay some years ago, and have not really switched back to MPC.  XMPlay works with everything but Real.  Unfortunately, with MPC, a lot of Real streams stop for me at about 1:20 in, with a server disconnect message.  I use MPC for all my video, though, and it works like a champ with the K-Lite Mega Pack.


    • synkdorbit

      synkdorbit - 2007-07-17

      Thanks... The streams I am having trouble with have video, so that XMPlay wouldn't be much use to me.

      The K-Lite Codec Pack is what I happen to have installed right now. Before that I was using just Real Alternative. Neither installation let me play the streams when using the MMS protocol.

    • synkdorbit

      synkdorbit - 2007-07-19

      Is there a debug mode somewhere? I'd sure like to be able to compare logs between a successful load on my laptop and my non-working one here.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks