0x7 error

  • Anonymous

    Anonymous - 2012-12-11


    I tried to boot a DVD iso image on my very old IBM pl-300, which will not boot from DVD.

    I wrote the floppy, booting works like a charm.
    I downloaded the iso-image to a hard disk and cabled it as a second master.

    Gujin will find the image, but after pressing "F1" to select the image, I get the error code 0x7 after 2-3 secs.

    What's going wrong?


  • Etienne LORRAIN

    Etienne LORRAIN - 2012-12-12

    Hi Wolf,

    Assuming you tried to load the El-Torito, i.e. selected "no-emul" way to boot your DVD, error 7 means that Gujin was not able to read one of the sector of the DVD (using its internal IDE/ATAPI driver) (line 4975 of main.c).
    I would either advise to try another DVD (physically badly written DVD) or open the DVD writer and clean the laser lenses (sometimes quite a lot of dust accumulate there…).
    Another solution to boot and install a Linux distribution on your PC is to create a partition of 8 Gbytes on your hard disk, copy the DVD there from another PC ("dd conv=fdatasync if=/dev/dvd of=/dev/sda4"), and run that DVD image from Gujin - installing for instance in /dev/sda1, it works for most distributions.
    After installation you can re-use /dev/sda4 for something else.



Log in to post a comment.