#10 Cannot Build latest git release of guitarix


I love this amp and have been using for about 2 years now. I recently migrated to a new Arch Install and wanted to get it running there. It's up to date and running Gnome 3.8.

I pulled from git and then ran:

[tom@lukepc trunk]$ git pull
Already up-to-date.

I then ran waf configure, which checked out

[tom@lukepc trunk]$ ./waf configure
Checking for program msgfmt : /usr/bin/msgfmt
Checking for program intltool-merge : /usr/bin/intltool-merge
Checking for program g++ or c++ : /usr/bin/g++
Checking for program cpp : /usr/bin/cpp
Checking for program ar : /usr/bin/ar
Checking for program ranlib : /usr/bin/ranlib
Checking for g++ : ok
Checking for jack <= 1.8.0 : yes
Checking for jack session support : yes
Checking for sndfile >= 1.0.17 : yes
Checking for gmodule-export-2.0 : yes
Checking for gtk+-2.0 >= 2.20 : yes
Checking for gthread-2.0 >= 2.24 : yes
Checking for glibmm-2.4 >= 2.24 : yes
Checking for gtkmm-2.4 >= 2.20 : yes
Checking for giomm-2.4 >= 2.24 : yes
Checking for fftw3f >= 3.1.2 : yes
Checking for lrdf : yes
Checking for header ladspa.h : yes
Checking for boost-system : yes
Checking for boost >= 1.42 : yes
Checking for zita-convolver >= 3.0 : yes
Checking for zita-resampler >= 1.0 : yes
Checking for program gperf : /usr/bin/gperf
Checking for program faust : /usr/bin/faust
Checking for faust version : ok 0.9.58

GUITARIX II 0.28.0git

OS : linux
C++ flags : -Wall -O3 -DNDEBUG
Link flags
Compiler ['/usr/bin/g++'] version : 4.8.1
Use prebuild faust files : no
Use faust precision : double
Use prebuild gperf files : no
Use internal zita-resampler : no
Use internal zita-convolver : no
Jack Session Support : yes
build ladspa plugins : yes
build lv2 plugins : no
skip Python Library Wrapper : yes
use prebuild C++ Library Wrapper : yes
skip building shared lib : yes
skip install lib-dev : yes
run ldconfig tool : yes
update desktop database : yes
Localization (intltool) : yes
skip glade support : yes
Install prefix : /usr/local
Install binary : /usr/local/bin
Install library : /usr/local/lib
Install ladspa : /usr/local/lib/ladspa
Guitarix shared files directory : /usr/local/share/gx_head
Guitarix pixmaps directory : /usr/local/share/pixmaps

'configure' finished successfully (4.284s)

Then, when I run waf build I get this error

[tom@lukepc trunk]$ ./waf build
Waf: Entering directory `/home/tom/Downloads/guitarix/trunk/build'
[163/331] dsp: src/faust/jconv_post_mono.dsp -> build/default/src/faust/jconv_post_mono.cc build/default/src/faust/jconv_post_mono.h
[164/331] dsp: src/faust/presence_level.dsp -> build/default/src/faust/presence_level.cc build/default/src/faust/presence_level.h
[165/331] dsp: src/faust/cabinet_impulse_former.dsp -> build/default/src/faust/cabinet_impulse_former.cc build/default/src/faust/cabinet_impulse_former.h
[166/331] dsp: src/faust/preamp_impulse_former.dsp -> build/default/src/faust/preamp_impulse_former.cc build/default/src/faust/preamp_impulse_former.h

File "../tools/dsp2cc", line 503
print self.modname, l
SyntaxError: invalid syntax
File "../tools/dsp2cc", line 503
print self.modname, l
SyntaxError: invalid syntax
File "../tools/dsp2cc", line 503
print self.modname, l
SyntaxError: invalid syntax
File "../tools/dsp2cc", line 503
print self.modname, l
SyntaxError: invalid syntax
Waf: Leaving directory `/home/tom/Downloads/guitarix/trunk/build'
Build failed:
-> task failed (err #1):
{task: dsp presence_level.dsp -> presence_level.cc,presence_level.h}
-> task failed (err #1):
{task: dsp jconv_post_mono.dsp -> jconv_post_mono.cc,jconv_post_mono.h}
-> task failed (err #1):
{task: dsp cabinet_impulse_former.dsp -> cabinet_impulse_former.cc,cabinet_impulse_former.h}
-> task failed (err #1):
{task: dsp preamp_impulse_former.dsp -> preamp_impulse_former.cc,preamp_impulse_former.h}

I tried the Arch User repository versions but they are very old or fail was well.

Any help would be appreciated.



  • Andreas Degert

    Andreas Degert - 2013-06-25

    Guitarix needs python2 for building and it seems you /usr/bin/python is python3. Easiest solution is to configure the build with --no-faust.

    The git version some checkins ago would also try to use gperf in a python script when its available, which also wouldn't work with python3.

    I just checked in changes that should make the scripts work with both python2 and python3. But be aware that the git version is under heavy development. The other option would be to use the last released version and configure with --no-faust.

  • Anonymous - 2013-06-27

    OK Thanks for your quick reply Andreas. For other reasons, I moved to OpenSuse and was able to waf install the current prod 0.27.1 and seems to be working great. I'll stink with tat for now. Thanks :)

  • Andreas Degert

    Andreas Degert - 2013-06-27
    • status: open --> closed
    • assigned_to: Andreas Degert


Cancel  Add attachments

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks