Receiving Unable to get property 'SHOW_CONNECTIONS' of undefined or null reference

Help
2014-04-18
2014-08-08
  • Grant Moyle

    Grant Moyle - 2014-04-18

    I'm receiving this message after logging into Guac
    "Unable to get property 'SHOW_CONNECTIONS' of undefined or null reference"
    after installed either 0.8.3 or 0.9.0 on a brand-new unbuntu box

     
  • Michael Jumper

    Michael Jumper - 2014-04-18

    Could you post the rest of the error from the logs?

     
  • Grant Moyle

    Grant Moyle - 2014-04-18

    This is shows on the webpage after I login
    Nothing is showing in syslog or catalina.out related to the error
    syslog shows Guac is running fine
    catalina shows my login, but nothing related to the error

     
    Last edit: Grant Moyle 2014-04-18
  • Michael Jumper

    Michael Jumper - 2014-04-19

    Which IE is this?

     
  • Vinny

    Vinny - 2014-06-27

    Since this morning I am getting the same error message (no reference to null in mine though : "Cannot read property 'SHOW_CONNECTIONS' of undefined".
    But I got this all of a sudden, with no apparent reason...

    I upgradded a few days ago from 0.8.3 to 0.9.1. I'm running an Ubuntu 12.04 server, with guacamole.war in tomcat7.
    Since I upgradded to 0.9.1, I'm experiencing quite some connection difficulties, getting the 15seconds timeout connection error messagebox on the client side.
    I tried with either IE7, chrome 35 or firefox 30.

    After I got this message once, I have to restart the tomcat server in order to get the home screen back. It still seems to load some the expected web page content, but nothings displays anymore until I restart tomcat...

     
  • Michael Jumper

    Michael Jumper - 2014-06-30

    IE7 is definitely not supported. The oldest IE having all JavaScript and HTML5 features required is IE10.

    As for Chrome and Firefox ... both should be working.

    To clarify a few things:

    Errors relating to being unable to read "SHOW_CONNECTIONS" are due to the failed loading of guac-ui.js, which is a static file. This specific script is listed within index.xhtml and client.xhtml before any others which depend on it. The only way that the object which has "SHOW_CONNECTIONS" could not exist is if guac-ui.js is not loaded by the browser, and the browser continues to execute the page anyway.

    When these static files are loaded, they come directly from Tomcat. There is no part of the Guacamole web application which controls whether individual JavaScript files can load. If the load of a specific static file is failing, something strange is going on.

    Can you check your browser's JavaScript or error logs if this happens again? There should be more information describing what is failing and how.

     
  • Vinny

    Vinny - 2014-07-01

    Hi Michael,

    Thanks for your time ! And sorry for my answering delay ! Actually, restarting my apache solved my problem... I really don't know what happened, but it may have to do with caching issues. My tomcat is behind a reverse proxying apache.

     
  • Robert Miller

    Robert Miller - 2014-07-22

    I too am having issues with IE10. I am running 0.9.1 and redirecting with Apache It works fine with Chrome once you set the proxycookiepath, however IE still does the same error, I noticed in debug of IE it uses a different Javasession value everytime like the cookie path is not set.

     
  • flop25

    flop25 - 2014-07-30

    Hi guys
    I'm having the issue too only ie IE10
    @Grant Moyle & @Robert Miller did you solve that?

    ps: updated to 0.9.2 without success
    all js files are loaded
    How did you for the Javasession?

    and use a direct link after authetification doesn't load anything, no requests to the tunnel

     
    Last edit: flop25 2014-07-30
  • flop25

    flop25 - 2014-08-01

    Okay that's getting weirder:
    with 0.9.2:
    On IE11 it send the request but the response is a 403 one, which is obviously wrong
    <html><head>Apache Tomcat/6.0.24 - Error report<style></style> </head><body>

    HTTP Status 403 -

    <HR size="1" noshade="noshade">

    type Status report

    message

    description Access to the specified resource () has been forbidden.

    <HR size="1" noshade="noshade">

    Apache Tomcat/6.0.24

    </body></html>
    On Firefox it worked once then getting
    Aug 1 20:31:45 ns363248 guacd[15636]: Starting client
    Aug 1 20:32:00 ns363248 guacd[15636]: Error reading instruction: Read timeout: Timeout while waiting for data on socket
    Aug 1 20:32:00 ns363248 guacd[15636]: Client finished normally
    even after many restart of guacd and tomcat
    *on IE10.0.10 in VM (bundled by ms), same than Firefox

    *with 0.9.1
    on IE11 still the Invalid login !?!
    on IE10.0.10 in VM and firefox no issue

    The problem is that IE10 at work cause the "Unable to get property 'SHOW_CONNECTIONS' of undefined or null reference" issue: do you know if something which can be blocked causes this? Or maybe a firewall/proxy issue?
    I will note their IE version next week

     
  • Robert Miller

    Robert Miller - 2014-08-05

    I have not been able to get it to work on IE remotely, the logs show that a user null tried to login. I did some more troubleshooting and see that the cookies for Java do not seem to be handled properly with IE. The java session ID gets changed with IE while it stays the same for Firefox and Chrome. I had this same thing happen (all browsers)when I had reverse cookie path not set correctly. This issues seems to have something to do with Apache redirects.

     
  • Michael Jumper

    Michael Jumper - 2014-08-05

    The "null" login attempt is normal - it's an authentication attempt via cookies, etc. only, and happens automatically for all pages within the Guacamole webapp.

    The constantly rotating cookie is definitely odd ...

    It might be interesting to compare what IE is sending Apache vs. the other browsers.

     
  • flop25

    flop25 - 2014-08-08

    Ps: at work that's IE10.0.18
    but it works now with guacamole 0.9.1... like Vinny it worked sunddently (Although I didn't restart Apache but only tomcat/guacd)
    I hate that random/multi-layers issues.