Various RDP issues

Help
2014-07-16
2014-07-22
  • Robert Miller

    Robert Miller - 2014-07-16

    First - to the developers thank you for the endless hours you have probably spent and continue to spend on this software. It is incredible.

    I do have a couple issues which most likely is user error, I have searched this board and used my best google-fu but cannot seem to find an answer. My setup is as follows...

    Server 1 Ubuntu Server 14.04
    Apache 2.47
    Virtualmin

    Server 2 Ubuntu server 14.04
    Apache 2.47
    webmin
    Virtualbox
    phpvirtualbox
    Guacamole 0.8.3 (installed via apt-get)
    Multiple Virtual Machines running win7 ultimate

    Browser Client Windows 7
    Chrome 35.0
    IE browser

    Server 1 has a public IP and I use Proxypass to forward rdp.mydomain.tld to server 2 to access guacamole server. I did have to add the proxypass cookies to get it to work, that was not in the manual. I set up remote desktop in each virtual machine to allow direct access to each box bypassing virtualboxRDP server. as it does not support sharing printers, drag and drop, etc. I do not like having these boxes open like this and want to find an RDP server that will work guacamole seems to have the capability.

    I can access any of my Virtual machines through guacamole, however I have the following problems.

    1. I cannot drag and drop either way. If I try to copy a file from the client to the remote desktop the browsers simply open the file.

    I have set the parameters for drive mapping but I do not see any virtual drive being created in the remote machine and the logs show no errors.
    <connection name="TestRDP">
    <protocol>rdp</protocol>
    <param name="hostname">10.1.10.189</param>
    <param name="port">5301</param>
    <param name="enable-printing">true</param>
    <param name="enable-drive">true</param>
    <param name="drive-path">/my documents/</param>
    </connection>

    1. Remote printing works to a pdf file, will this ever support actually printing to the client printer? It shows the printer name like it is the client printer but it only prints to pdf.

    I am trying to have a system as idiot proof as possible. Currently clients use microsoft RDP connections to access their remote desktops, printing, sound, drag and drop etc. all work using microsofts rdp. If I can get these issues resolved, I believe I have a great solution for my clients.

    sorry for the long post, if anyone has any ideas please let me know.

     
  • Robert Miller

    Robert Miller - 2014-07-17
    • Update

    I loaded 0.9.1 .war file and now it lists 0.9.1 when I go to the site. Now it will allow me to drag a file into the window, it opens the file transfer window but it stays at 0%. No errors that I can find in any logs.

     
  • Robert Miller

    Robert Miller - 2014-07-18

    Does anyone respond to issues on this board?

     
    • Michael Jumper

      Michael Jumper - 2014-07-18

      Yes, but please be patient. If no one responds, I tend to swoop in after a couple days, but I'm otherwise very busy coding. This week is particularly hectic, being the end of our current development sprint.

       
  • Michael Jumper

    Michael Jumper - 2014-07-18

    When you attempt to upload files, do you seen any errors in syslog?

    Your "drive-path" parameter is set at "/my documents/", but is this what you truly intend? The drive path refers to a path on the server hosting guacd. In this case, guacd will attempt to put files uploaded for this connection into a directory called "my documents" in the filesystem root.

    The "drive-path" parameter does not refer to a directory or path on the RDP server.

    Regarding printing, no, sadly, it's not possible to print directly to a client printer. Web browsers and JavaScript simply don't provide that kind of access for security reasons. The best possible is to print to a PDF via guac, and then open and print that PDF locally.

     
  • Robert Miller

    Robert Miller - 2014-07-21

    Sorry Mike, I was getting swammped myself. As for errors no I dont see anythign in any of the error logs. As far as where the folder is mapped to I am running guac on a ubuntu box, I created a directory /my documents/ in linux that is user read/write.

    Now I have different problems. I tried to upgrade and now clicking the login does nothign and the logs show that user "Null" tried to access. Of course I had a username and pass typed in. I have cleared cache and restarted guac and tomcat to no avail.

     
  • Robert Miller

    Robert Miller - 2014-07-22

    OK as far as the connection problem goes, if I look at the logs all I see is that user Null tried to login. I can access everything no problem locally. It may be a setting in Apache as I am forwarding to a internal server. I am not sure why that would have changed as it was working.
    If I debug in chromme I get the error:
    GET http://myserver:8080/guacamole/connections 403 (Forbidden) although I see this error even locally?!?1

     
  • Robert Miller

    Robert Miller - 2014-07-22

    The key "target-densitydpi" is not supported. index.xhtml:29
    GET http://10.1.10.56:8080/guacamole/connections 403 (Forbidden) service.js:513
    GuacamoleService.Connections.list service.js:513
    GuacamoleRootUI.reset root-ui.js:229
    (anonymous function) root-ui.js:510

     
  • Robert Miller

    Robert Miller - 2014-07-22

    OK the connection issue turned out to be a ID10T error. Or PEBCAK error
    when using apache frontend to pass to an internal server the reverse cookie path directive is required. the full path is needed including server.

    Apache directives to forward requests to internal server

    ProxyPreserveHost On
    ProxyRequests Off
    ProxyPass / http://IP address or hostname of internal server:8080/guacamole/ max=20 flushpackets=on
    ProxyPassReverse / http://IP address or hostname of internal server/guacamole/
    ProxyPassReverseCookiePath / http://IP address or hostname of internal server/guacamole/