On Wed, Aug 31, 2011 at 19:32, Riccardo Merlotti <dennymallow@gmail.com> wrote:
Hi everybody, I'm trying to get gtkpod working after latest update in Arch.
The update came up with latest kernel, and now the "uname -r" command shows up:


I tried both to pull the git version and download and install the 2.1.0 version from the website, but in both cases after a successful (I suppose!) compiling process (./configure or ./autogen.sh, then make and finally sudo make install) I obtain the same result:

gtkpod: error while loading shared libraries: libgnutls.so.26: cannot open shared object file: No such file or directory

I noticed with a locate that the situation for gnutls modules is as follows:


Maybe this is the issue? I finally noticed that symlinkig the .26 module in /usr/lib produces this error:

wrong ELF class: ELFCLASS32

I'm no expert on this error, but my guess is that gtkpod is compiled against version .26 for 64 bits, but you only have the 32-bit library for that version. You can verify by running file `which gtkpod` and also running file on the relevant libraries.

I don't think the kernel version matters (if anything, the target architecture; try uname -a).

Any hep would be appreciated, if you need additional info I'm here for you.



Special Offer -- Download ArcSight Logger for FREE!
Finally, a world-class log management solution at an even better
price-free! And you'll get a free "Love Thy Logs" t-shirt when you
download Logger. Secure your free ArcSight Logger TODAY!
Gtkpod-devel mailing list