On 27 May 2014 16:48:32 GMT+01:00, Flavio <flapane@gmail.com> wrote:
Il 27/05/2014 12:18, phantomjinx ha scritto:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

<snip>
Hi Paul,

I installed a few missing dependencies from your list. However I still get a: ****************
checking for faad... no configure: WARNING: "Cannot find faad. Conversion from m4a to mp3 not
possible" M4A File Type .....: no **************** for both v2.1.4 and git
version. That's curious... didn't you experience such issue while running ./configure?

Also, upgrading to gstreamer v1.0 looks great, but if I update (git pull) the gtkpod-code
revision I downloaded one week ago, it tells me that it's already up to date.

Regards, Flavio
This is anything to do with faad that I installed
ii faad 2.7-8
ii gstreamer1.0-plugins-bad-faad:i386 1.2.3-1ubuntu2
ii libfaad-dev:i386 2.7-8
ii libfaad2:i386 2.7-8

This is the important part of the configure script:

dnl Check for faad for use filetype_m4a plugin
dnl

have_faad="no"

AC_CHECK_PROG(FAAD, faad, yes, no)
if test "x$FAAD" = "xyes"; then
have_faad="yes"
else
AC_MSG_WARN(["Cannot find faad. Conversion from m4a to mp3 not possible"])
fi

Its looking for the actual binary 'faad', which gets installed to /usr/bin and belongs
to the faad package.

I have pushed the gstreamer upgrades to the repository. Are you using the sf updated git
repo?

This is the latest commit:
https://sourceforge.net/p/gtkpod/code/ci/7439f2094d69185b5ec7b1b27b6a8137210cc215/

PGR


Thanks,
it looks like there was something wrong with faad package or with apt
system.
apt showed it as "installed" but, actually, it wasn't (or the
installation didn't complete). I guess something went wrong in the
upgrading process from Ubuntu 13.10 to 14.04

Now v2.1.4 compiles flawlessy.
However, git version (updated to the latest commit) compilation halts at
the very beginning, even if ./autogen.sh look ok to me.
I wonder if it's related to gstreamer1.0 or libmusicbrainz-5 (I doubt
that). It looks like it has something to do with GTK version of Ubuntu
14.04, which is v3.10.8.
Attached is the compilation output.

[...]
checking for GTK... yes
checking for GLIB... yes
checking for GDK... yes
checking for GMODULE... yes
checking for GTHREAD... yes
checking for LIBGPOD... yes
checking for LIBANJUTA... yes
checking for LIBGDL... yes
checking for GIO... yes
checking for LIBXML... yes
checking for ID3TAG... yes
Checking optional dependencies
checking for CLUTTER_GTK... yes
checking for CURL... yes
checking for WEBKIT... yes
checking for GSTREAMER... yes
checking for VORBISFILE... yes
checking for FLAC... yes
checking for BRASERO... yes
checking for MUSICBRAINZ5... yes
checking for DISCID... yes
checking GStreamer 1.0 element vorbisenc >= 1.0... found
checking GStreamer 1.0 element flacenc >= 1.0... found
checking GStreamer 1.0 element wavenc >= 1.0... found
checking GStreamer 1.0 element giosink >= 1.0... found
[...]

Plugin Configuration :


CoverWeb Browser .....: yes
Media Player .....: yes
MP4 File Type .....: yes
M4A File Type .....: yes
Flac File Type .....: yes
Ogg File Type .....: yes
Clarity Display Widget .....: yes
Sound Juicer Widget .....: yes
Support for cover download .....: yes -- will build with coverart
download support

Now type 'make' to build gtkpod 2.1.5~7439f20,

Those errors are due to deprecations being compile errors. Releases turn this off and I have also added a switch to configure to manually turn it off, (configure --enable-deprecations).

Still bugs but might get you farther along.

PGR