My wife got a red (xC050) Nano Video 5G for Christmas. We named it PinkiPod because I wasn't sure of the colour :). I had it reset on a Vista system so it is VFAT32. I'm running Kubuntu 9.10 with Amarok 2.2.2 on KDE 4.3.2 with the latest Kubuntu versions of libgpod and gtkpod. The first time I tried the iPod with Amarok it wanted to initialise and I did that. I transferred several tunes from Amarok to the iPod. It seemed to work, they show up in Amarok, but when I ejected the iPod it showed 0 songs. I've searched and tried to get this fixed. I think I got the correct model number, xC050, as I do see it showing a sync operation when I attach it to Amarok. I put this model number and the FirewireGuid into the sysinfo file. I then ran the "sudo ipod-read-sysinfo-extended /dev/sdf1 /media/PINKIPOD" command successfully, it appears. Still 0 songs. I open the device with gtkpod and get a warning that the extended-sysinfo will not be used. It appears to transfer songs, but still 0 songs on the iPod.

If I start gtkpod as root I get messages -

iTunesDB '/media/PINKIPOD/iPod_Control/iTunes/iTunesDB' does not match checksum in extended information


gtkpod will try to match the information using SHA1 checksums. This may take a long time.

I press OK and nothing seems to happen.

Is the Nano Video 5G still an issue or am I doing something wrong?

An old mainframer getting current.