Hello, I'm running Ubuntu 12.04 64bit, and when trying to install happindicator to try to the indicator example[1] on the Ubuntu App Developer site, I get the following output:

$ cabal install happindicator
Resolving dependencies...

/tmp/happindicator-0.0.4-2272/happindicator-0.0.4/Gtk2HsSetup.hs:25:2:
     warning: #warning Setup.hs is guessing the version of Cabal. If compilation of Setup.hs fails use -DCABAL_VERSION_MINOR=x for Cabal version 1.x.0 when building (prefixed by --ghc-option= when using the 'cabal' command) [-Wcpp]
[1 of 2] Compiling Gtk2HsSetup      ( /tmp/happindicator-0.0.4-2272/happindicator-0.0.4/Gtk2HsSetup.hs, /tmp/happindicator-0.0.4-2272/happindicator-0.0.4/dist/setup/Gtk2HsSetup.o )
[2 of 2] Compiling Main             ( /tmp/happindicator-0.0.4-2272/happindicator-0.0.4/Setup.hs, /tmp/happindicator-0.0.4-2272/happindicator-0.0.4/dist/setup/Main.o )
Linking /tmp/happindicator-0.0.4-2272/happindicator-0.0.4/dist/setup/setup ...
Configuring happindicator-0.0.4...
setup: The pkg-config package appindicator-0.1 is required but it could not be
found.
cabal: Error: some packages failed to install:
happindicator-0.0.4 failed during the configure step. The exception was:
ExitFailure 1


I wasn't sure if it was looking for an Ubuntu repo package, but the only thing I see in the repo with a similar name is gir1.2-appindicator-0.1. Is there anything I can do to make this work? Thanks!

[1] http://developer.ubuntu.com/resources/technologies/application-indicators/