GSVideo in Eclipse

Help
2011-09-12
2012-12-26
  • Guy Yitzhaki

    Guy Yitzhaki - 2011-09-12

    Hi,
    I'm trying to get GSVideo to work in an Eclipse Java project. I'm using GSVideo 0.9, and it works fine on my Windows 7 machine in the Processing PDE. I added GSVideo.jar, gstreamer-java.jar and jna.jar to the java build bath, as well as the gstreamer directory.
    When I try to launch one of the examples I get the message
    can't load library SDL (SDL|libSDL|libSDL-0) with -Djna.library.path=C:/dev/workspace/GSVideoTest/lib/user/GSVideo\gstreamer\win. Last error:java.lang.UnsatisfiedLinkError: Unable to load library 'SDL': The specified module could not be found.

    for a long series of libraries. The directory that appears in the error message is the correct path to the gstreamer directory.
    Am I missing something?

    Thanks,
    Guy

     
  • Guy Yitzhaki

    Guy Yitzhaki - 2011-09-12

    Solved - changing the project JRE to use the one in the Processing installation fixed the load library errors, and the application works fine now.
    Only issue left is that when I close the application window I get a message saying that the "Java Platform SE binary has stopped working", and need to force the program to close.

     
  • Guy Yitzhaki

    Guy Yitzhaki - 2011-09-12

    solved this too - just in case it helps anyone in the future -
    overriding PApplet.stop and calling movie.stop solved the JRE error message

    public void stop() {
    movie.stop();
    super.stop();
    }

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks