GSCapture on Snow Leopard (via Linux)?

Cefn Hoile
  • Cefn Hoile

    Cefn Hoile - 2012-02-20

    I can't get GSCapture operational within an Eclipse-authored app for Snow Leopard, although 1.0.0 and 200110709 both work within Processing on both Ubuntu (where I develop) and Snow Leopard (my target). What am I missing?

    I'm trying to use unstable (20110709) in the vain hope that I can get the same code to run on Ubuntu and Snow Leopard, but would consider any configuration of GSCapture which works on an Eclipse-authored app on Snow Leopard, especially with a way to select a secondary camera.

    There must be a step which is automatic when sketches are run in Processing, but which I'm failing to do when using the capture library within an Eclipse-authored App on Snow Leopard, but what is it?

    I have GSCapture 1.0.0 working within my Ubuntu build in both Processing-authored and Eclipse-authored java apps but can't find any Eclipse-based configuration (tried almost every set of jars in sourceforge download) which will serve frames from the iSight on the Snow Leopard machine, hence the need to try something else.

    Still more problematic I've no idea how to specify the 'camera name' on Snow Leopard at all. In the end I'll need to select a secondary camera, not the iSight.

    On both my Ubuntu machine and Snow Leopard machine, I have GSCapture 20110709 working using the AsciiVideo demo sketch within Processing. However, the code which works on GSCapture 1.0.0 on Linux produces only a black image when I replace the jars with the 20110709 version. I've added a .start() invocation in case the GSCapture object needs a kick, but still no frames being written.


  • Andres Colubri

    Andres Colubri - 2012-02-21


    My initial guess is that the native libraries are not being properly loaded when you run the application on OSX. If you start it from the terminal, do you see any error message?

    The GSVideo class has a static variable called localGStreamerPath where you can hard code the location of the gstreamer libs, before you do any other GSVideo call. Something like this:

    setup() {
      size(320, 240);

      GSVideo.localGStreamerPath = "/home/user/gstreamer/libs"

      cam = new GSCapture(…);

    Maybe this can help, if the problem is with the native libs.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks