Problem reading video

Help
2013-06-21
2013-06-24
  • Ricardo Alves

    Ricardo Alves - 2013-06-21

    Hello,

    I've used your library in processing. Ii wanted to use your library in one of my projects (using netbeans) but I get some problem when running one example (even in processing). When I try to run some video example I always get this error:

    error, disabling movieEvent() for station.mov
    java.lang.reflect.InvocationTargetException

    The examples I've tried to run were:

    • Movie/Frames
    • Movie/Loop

    What am I doing wrong? Do I need to install something?
    When I run the examples from the built-in processing library (their examples are almost like yours) it gives me no error and works fine, but when I downloaded your library and copy into processing external libraries I get that error.

    Thanks in advance,
    Ricardo Alves.

     
  • Andres Colubri

    Andres Colubri - 2013-06-24

    Hello Ricardo,

    When using Processing and GSVideo from Eclipse or Netbeans, you need to set the movieEvent() as public (the pre-processor in the PDE automatically does this for you). The error you are getting makes me think that this is one possible issue in your code.

    Andres

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks