Hi Felipe,

    I'm Working Gst-openmax with bellagio componets... While palying 3gp video file by using gst-launch tool i'm getting the below problem..

gst-launch filesrc location=sample-rnl-h263-cif.3gp ! qtdemux ! queue ! omx_h263dec ! omx_videosink

0:00:00.159365692 20995 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "filesrc"
0:00:00.161694054 20995 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "qtdemux"
0:00:00.161928176 20995 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "queue"
In file 'gstomx.c'--> plugin-init()    ---START---
In file 'gstomx.c'--> plugin-init ()   ---END--254 e
0:00:00.166579033 20995 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "omx_h263dec"
0:00:00.166750573 20995 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "omx_videosink"
0:00:00.167206523 20995 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "pipeline"
Setting pipeline to PAUSED ...
OMX-Component not found with current ST static component loader.
ERROR: Pipeline doesn't want to pause.
Setting pipeline to NULL ...

As per ur suggstion for Beagle-Board for TI we have tried the same command on my PC for Bellagio..then also it is giving the error like this..

 gst-launch filesrc location=ATI-9700-rnl-h263-cif.3gp ! ffdemux_amr ! queue ! omx_h263dec ! omx_videosink  library-name="/usr/local/lib/bellagio/libomxfbdev.so" component-name="OMX.st.fbdev.fbdev_sink"

0:00:00.162751513 21056 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "filesrc"
0:00:00.276647650 21056 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "ffdemux_amr"
0:00:00.276974806 21056 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "queue"
In file 'gstomx.c'--> plugin-init()    ---START---
In file 'gstomx.c'--> plugin-init ()   ---END--254 e
0:00:00.282168500 21056 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "omx_h263dec"
0:00:00.282347304 21056 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "omx_videosink"
0:00:00.282816944 21056 0x804e050 INFO   GST_ELEMENT_FACTORY gstelementfactory.c:399:gst_element_factory_create: creating element "pipeline"
Setting pipeline to PAUSED ...
OMX-Component not found with current ST static component loader.
ERROR: Pipeline doesn't want to pause.
Setting pipeline to NULL ...
FREEING pipeline ...

We dont know the problen that we r facing with ST-static component loader..and what is the library-name we have to use???
Could you please suggest me to resolve this problem..

Thanks & Regards
  Vali..