The problem seems to be fixed by manually setting GST_PLUGIN_PATH to /usr/lib/gstreamer-0.10.

Thanks and regards,
Ravi Karmarkar

On Tue, May 26, 2009 at 5:09 PM, Ravi Karmarkar <karmarkar.ravi@gmail.com> wrote:

I tried your suggestion..... gst-inspect-0.10 /usr/lib/gstreamer-0.10/libgstcoreelements.so

Following is the output:

Plugin Details:
  Name:            coreelements
  Description:        standard GStreamer elements
  Filename:        /usr/lib/gstreamer-0.10/libgstcoreelements.so
  Version:        0.10.22
  License:        LGPL
  Source module:    gstreamer
  Binary package:    GStreamer source release
  Origin URL:        Unknown package origin

  capsfilter: CapsFilter
  fakesrc: Fake Source
  fakesink: Fake Sink
  fdsrc: Filedescriptor Source
  fdsink: Filedescriptor Sink
  filesrc: File Source
  identity: Identity
  queue: Queue
  filesink: File Sink
  tee: Tee pipe fitting
  typefind: TypeFind
  multiqueue: MultiQueue

  12 features:
  +-- 12 elements

which means that fakesrc is in fact installed? How to specify the correct search path in that case?

Thanks and regards,
Ravi Karmarkar

Date: Tue, 26 May 2009 09:41:01 +0100
From: Tim M?ller <tim.muller@collabora.co.uk>
Subject: Re: [gst-embedded] gst-launch problem
To: gstreamer-embedded@lists.sourceforge.net
Message-ID: <1243327261.4399.3.camel@mini.centricular.net>
Content-Type: text/plain

On Tue, 2009-05-26 at 16:14 +0800, Ravi Karmarkar wrote:

> I have installed GStreamer-0.10.22 to be used with swfdec-0.8.4 for my
> sh4 platform.

Please note the latest version is 0.10.23.

> After installation I tried to run the test
> gst-launch -v fakesrc num_buffers=5 ! fakesink

> and got the error ERROR: pipeline could not be constructed: no element "fakesrc".
> What is the cause of this error? My libraries are installed in /usr/lib/gstreamer-0.10 and when I try to grep for fakesrc in this directory, I see that following files contain 'fakesrc'

Hard to say without more information. You could try this:

 $ gst-inspect-0.10 /usr/lib/gstreamer-0.10/libgstcoreelements.so

to see if it's a search path problem or something else.

In the unlikely case that you have not disabled the debugging system,
you could run

 $ GST_DEBUG=*:3 gst-inspect-0.10 fakesrc 2>dbg.log

and see if you spot anything suspicious/wrong.