Thanks for your response. I will give the newer version of gst-ffmpeg a try (I hope building it isn't too much of a headache and that it will be binary compatible). I also looked at the DShow decoder wrapper, but somehow cannot instantiate it. I tried the following code:

GstElement* videoDecodebin = gst_element_factory_make ("dshowdecwrapper", "videodecodebin");

This always gives me a null object. I know I have the bad plugins installed and gst-inspect does give me some reasonable output. Any thoughts on what I might be missing?

The documentation is pretty light on this one but from what I could tell based on the output from gst-inspect and the source code itself, it doesn't look like this will actually work with VC1 (aka WMV9 AP, fourCC: WVC1). I am assuming that this is because I am not using the latest version from CVS, correct? Or am I missing something?

Thanks again,

Andreas


On 3/29/08, Edward Hervey <edward.hervey@collabora.co.uk> wrote:
Hi,

  Even though VC1 support was added a long time ago in ffmpeg,
gst-ffmpeg uses specific revisions of upstream ffmpeg (for reasons
outside the scope of this mail).
  The latest release of gst-ffmpeg (0.10.2) was still using a revision
from a long time ago.

  The current cvs head of gst-ffmpeg uses a much recent revision, with
which VC1 indeed works.
  You could also, if you're on windows, use the directshow wrappers
available in -bad. They will provide VC1 support (amongst other
formats).

   Edward


On Fri, 2008-03-28 at 16:42 -0500, Andreas Schuler wrote:
> Hi all,
>
> I am currently evaluating GStreamer for a project I am working on. The
> bulk of the content I am dealing with is encoded in VC-1 (WMA for
> audio). I have spent quite a bit of time getting more familiar with
> the GStreamer concepts but I have not been able to play back a WMV
> file (with VC-1 encoded video) yet.
>
> I have tried using the playbin, playbin2, as well as a custom built
> pipeline (using the decodebin). I also tried with the ASF demuxer so I
> could inspect the video caps at its output. There I was able to
> confirm that the fourcc is correctly identified as WMVC1.
>
> Despite a number of attempts I have not been able to get my WMV file
> to show any video (audio is working fine). I have tried other files
> (xvid encoded), which are working fine.
>
> I assumed that this should work since ffmpeg has been supporting VC-1
> decoding for some time now.
>
> I am using the following versions (mainly because those are the most
> recent Windows binaries available):
>
> GStreamer: 0.10.17
> gst-plugins-base: 0.10.17
> gst-plugins-good: 0.10.7
> gst-plugins-bad: 0.10.6
> gst-plugins-ugly: 0.10.7
> gst-ffmpeg: 0.10.2
>
> Can anyone tell me whether VC-1 is currently supported by GStreamer
> (on Windows and other platforms), or whether there must be a problem
> with my setup somehow? Also, if VC-1 currently isn't supported, are
> there any plans to include that in the near future? And, will VC-1
> encoding also available at some point?
>
> Thanks,
>
> Andreas
>
>
>
>
>

> -------------------------------------------------------------------------
> Check out the new SourceForge.net Marketplace.
> It's the best place to buy or sell services for
> just about anything Open Source.
> http://ad.doubleclick.net/clk;164216239;13503038;w?http://sf.net/marketplace
> _______________________________________________ gstreamer-devel mailing list gstreamer-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/gstreamer-devel

--
Edward Hervey
Lead Platforms Engineer / Director
Collabora Multimedia




--
Andreas Schuler
CTO
Neokast LLC
Metis Enterprise Technologies LLC
990 Grove St. Suite #401
Evanston, IL 60201
847.328.7265
847.328.7276 (F)
262.327.1034 (C)
andreas@neokast.com