Hi,

I have 2 Freescale iMX27 ADS evaluation boards, and trying to stream the compressed video from one board to the other over Ethernet. Following are the commands I used, but I don't see any videos from the receiving board display:

---------------------------------------------------------------------------------------------------------------------------------------

Board A:

gst-launch-0.10 -v mfw_v4lsrc ! mfw_vpuencoder width=176 height=144  codec-type=std_h263   ! rtph263ppay  ! udpsink host=10.29.244.26 port=5434

 

Board B:

gst-launch  --gst-debug-level=2 -v udpsrc port=5434 caps = "application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)H263-1998, ssrc=(guint)1920285880, clock-base=(guint)3978748897, seqnum-base=(guint)10249" ! rtph263pdepay !  mfw_vpudecoder codec-type=std_h263  ! mfw_v4lsink

 

---------------------------------------------------------------------------------------------------------------------------------------

Board A:

gst-launch -v filesrc location= kuuba_maisema_25fps_qcif.yuv blocksize=38016 ! mfw_vpuencoder width=176 height=144 framerate=25 codec-type=std_mpeg4   ! rtpmp4vpay  ! udpsink host=10.29.244.26 port=5434

 

Board B:

gst-launch  udpsrc port=5434 caps = "application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)MP4V-ES, ssrc=(guint)2934921665, clock-base=(guint)1608131808, seqnum-base=(guint)10897, profile-level-id=(string)2, config=(string)000001b002000001b59113000001000000012000c488800f50584121443f" ! rtpmp4vdepay !  mfw_vpudecoder codec-type=std_mpeg4  ! mfw_v4lsink

---------------------------------------------------------------------------------------------------------------------------------------

Anyone has any ideas.

Thanks,