Error on Create

Help
2008-10-16
2013-03-26
  • Giuliano Lovisotto

    Hi, I have just installed Gspiceui on Ubuntu 8.04 and when I try to create a simulation from a netlist file it returns me an error.
    "Error invalid start sweep time", I am trying to create a Transient simulation with Start 0ms, end 10ms step 100us (no source selected).
    I do not know why, I tried to use ngspice with command line and it works (with tran 100us 10ms).
    Thanks

    Giuliano

     
    • Mike W.

      Mike W. - 2008-11-21

      I've just try to do transient analysis using the sweep settings you've quoted above using both
      NG-Spice and GNU-Cap and both worked.

      Perhaps you could send me your netlist and tell me the version of gSpiceUI you are using
      and where you got it from eg. a package or source code.

       
      • Giuliano Lovisotto

        Thank you for the support.
        I installed with apt-get the version 0.9.55.dfsg-1.
        Before I installed (from source) ng-spice-rework-17 e with apt-get gnucap 1:0.35-1

        The netlist I have loaded is reported below:

        [quote]
        * gnetlist -g spice-sdb mySPICE.sch
        *********************************************************
        * Spice file generated by gnetlist                      *
        * spice-sdb version 4.28.2007 by SDB --                 *
        * provides advanced spice netlisting capability.        *
        * Documentation at http://www.brorson.com/gEDA/SPICE/   *
        *********************************************************
        *vvvvvvvv  Included SPICE model from /home/ubuntu/Documenti/FilesElettronica/MyLibSpice/spice/ua741.inc vvvvvvvv
        * UA741 operational amplifier "macromodel" subcircuit
        * created using Parts release 4.01 on 07/05/89 at 09:09
        * (REV N/A)
        * connections:   non-inverting input
        *                | inverting input
        *                | | positive power supply
        *                | | | negative power supply
        *                | | | | output
        *                | | | | |
        .subckt UA741    1 2 3 4 5
        *
          c1   11 12 4.664E-12
          c2    6  7 20.00E-12
          dc    5 53 dx
          de   54  5 dx
          dlp  90 91 dx
          dln  92 90 dx
          dp    4  3 dx
          egnd 99  0 poly(2) (3,0) (4,0) 0 .5 .5
          fb    7 99 poly(5) vb vc ve vlp vln 0 10.61E6 -10E6 10E6 10E6 -10E6
          ga    6  0 11 12 137.7E-6
          gcm    0  6 10 99 2.574E-9
          iee  10  4 dc 10.16E-6
          hlim 90  0 vlim 1K
          q1   11  2 13 qx
          q2   12  1 14 qx
          r2    6  9 100.0E3
          rc1   3 11 7.957E3
          rc2   3 12 7.957E3
          re1  13 10 2.740E3
          re2  14 10 2.740E3
          ree  10 99 19.69E6
          ro1   8  5 150
          ro2   7 99 150
          rp    3  4 18.11E3
          vb    9  0 dc 0
          vc    3 53 dc 2.600
          ve   54  4 dc 2.600
          vlim  7  8 dc 0
          vlp  91  0 dc 25
          vln   0 92 dc 25
        .model dx D(Is=800.0E-18)
        .model qx NPN(Is=800.0E-18 Bf=62.50)
        .ends
        *^^^^^^^^  End of included SPICE model from /home/ubuntu/Documenti/FilesElettronica/MyLibSpice/spice/ua741.inc ^^^^^^^^
        *
        *==============  Begin SPICE netlist of main design ============
        R2 1 out 100K 
        R1 in 1 10K 
        XOA1 0 1 3 2 out UA741
        VCC 3 0 DC 12
        Vin in 0 sin 0 1 1KHZ
        VEE 2 0 DC -12
        .end
        [/quote]

        I selected "ngspice" engine and after I selected "Transient"
        If I try to create a simulation from  this netlist I get "Invalid Sweep Start Value".

         
      • Giuliano Lovisotto

        I do not know If it could be useful but I have tried another netlist (simpler).
        It gives me the same error so I think it does not depend to the netlist.
        I tried:

        * gnetlist -g spice-sdb prova.sch
        *********************************************************
        * Spice file generated by gnetlist                      *
        * spice-sdb version 4.28.2007 by SDB --                 *
        * provides advanced spice netlisting capability.        *
        * Documentation at http://www.brorson.com/gEDA/SPICE/   *
        *********************************************************
        *==============  Begin SPICE netlist of main design ============
        R2 out 0 100K 
        R1 in out 10K 
        Vin in 0 sin 0 1 1KHZ
        .end

        what I suppose is I have not correctly installed all components.
        gSpiceUI returns an error if it does not find ng-spice and/or GNUCAP?
        the error is the same with this netlist too ("Invalid sweep start value")

        The installation procedure I follow is reported below:

        1) gEDA (version 1:1.4.0-1) installation
        apt-get install geda

        2) GNUCAP (version 1:0.35-1) installation
        apt-get install gnucap

        3) ng-spice installation
        download ng-spice-rework-17.tar.gz
        tar -xvvzf ng-spice-rework-17.tar.gz
        cd ng-spice-rework-17
        sudo su
        apt-get install libc6-dev
        apt-get install build-essential
        ./configure --enable-xspice --with-readline
        make
        sudo make install

        4) gspiceui (version 0.9.55.dfsg-1) installation
        apt-get install gspiceui

        finished

        After that I created the schematic (netlist reported on top).
        I lunched by command line

        gnetlist -g spice-sdb prova.sch

        I lunched gspiceui, load the netlist, set all transient parameters and try to create simulation.
        Here I got the error.
        Sorry for the long post but I tried to give you as more information as possible
        Thank you very much

        Giuliano

         
    • Mike W.

      Mike W. - 2008-12-01

      I use Fedora 8 and 9. I've tried reproducing the fault you've reported without
      success (or is that failure). I've tried gSpiceUI v0.9.65 and v0.9.55 compiled
      from the sources and v0.9.65 from precompiled packages from the Web.

      This is not exactly the same as you're setup but it's as close as I can get.

      I notice that there is an Ubuntu release of gSpiceUI v0.9.65, could you
      try the newer version?

      I'm currently working on the v1.0.0 release of gSpiceUI. It internally differs
      significantly from previous versions so looking at the latest sources isn't
      much good to identify this fault. In addition the new code is still pretty
      broken so I can't give that to you either.

      Mike W.

       
    • Giuliano Lovisotto

      I have checked the correct installation of ngspice. it works with the same parameters I set to gSpiceui.
      I cannot test the 0.65 version because it is available only for Intrepid Ibex version (I have Hardy Heron).
      I tried also to install gSpiceui from sources but I was not able ... I will try later (when I tried make it return me many errors).
      Thanks for the support

      Giuliano

       
    • Giuliano Lovisotto

      Important update: I find a way to overcome the error.
      The problem I think is related to the number format.
      The default sweep start value is 0,00 but it does not work and this is the reason I got the error.
      If I change this value with 0 (removed comma and decimal part) I do not get the error.
      At the end gspiceui does not work because I think the problem affects all numbers ...
      I do not understand why I am the only one who have the problem.

      Giuliano

       
    • Giuliano Lovisotto

      I recorded the video with problem self explaning. At the end the simulations return false results (all points to 9.99e+99).
      With ngspice without gspiceui I got the good results.
      I hope this will help you to find the problem.
      The video has been uploaded at youtube: http://it.youtube.com/watch?v=gzjC7sUn7oY

      Giuliano

       
    • Giuliano Lovisotto

      After some tries I recompiled the sources 0.9.65 with the patch I found in the gspiceui tracker (https://sourceforge.net/tracker/index.php?func=detail&aid=1576729&group_id=145635&atid=762570) and now all works fine (many thanks to Werner).
      It seems to be a problem well known of wxGTK.
      I hope it will be fixed in the next version.
      Thanks to all

      Giuliano

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks