Ignoring soundbank.gm?

Help
bp99
2009-09-16
2013-05-08
  • bp99

    bp99 - 2009-09-16

    In my workspace I have a file soundbank.gm which is a binary file. However, Groovy Monkey inserts a script header into it. I did not find a way to configure Groovy Monkey to ignore certain files or folders. Any help would be greatly appreciated.

    By the way, is there a better, i.e. more active, forum or mailing list to post questions about Groovy Monkey on?

    Cheers,
    Bernhard

     
  • James E. Ervin

    James E. Ervin - 2009-09-16

    Well this is as good as any place to do it.  I do get notified here.  There is no way to configure it currently to ignore files. 

    I am going to need to think about the solution and put in a code fix.  You know to be honest I hadn't thought that other apps would use .gm as a file suffix.  I suppose I should be careful about my assumptions…

    I think the fix will be to check to see if the file is a monkey script and to not update the header otherwise (i.e. it is missing).  This is a general problem I think.  Follow up with me about this…

     
  • James E. Ervin

    James E. Ervin - 2009-09-16

    I do have one question.  Does this occur when you open the file in an editor?  Or does it happen no matter what?

     
  • bp99

    bp99 - 2009-09-21

    Thanks for the fast response!

    To answer your question: It happens even if I don't open the file in an editor. I tried to fix it by replacing the file from the latest in CVS but Groovy Monkey inserts the script header immediately.

    I have thought of the following solutions:

    a) Add a list of filenames to ignore
       to the preferences. I would add
       soundbank.gm in that case.

    b)
       Introduce a preference to deactivate
       the automatic insertion of the script
       header.

    I think I prefer b) because I consider the automatic insertion a little dangerous anyway. If we had not checked in the soundbank.gm I would probably not have seen the problem at all.

    Cheers,

    Bernhard

     
  • bp99

    bp99 - 2009-09-29

    I wonder what you think about the possible solutions.

    Cheers,

    Bernhard

     
  • James E. Ervin

    James E. Ervin - 2009-10-08

    I am sorry I have not had the chance to reply.  I think you are right about the possible solutions.  Perhaps the monkey plugin should not assume about files, checking first that they are indeed text based and secondly, check to see whether they were monkey files to begin with.  Or perhaps give the user a chance to define their own suffix for monkey files… Hmm… I will have to think about this.

    Keep on me about this, I have been in flux recently, but this is an issue that needs to be resolved.

     
  • bp99

    bp99 - 2009-10-13

    Thanks for your reply. Let me know if I can be of any help.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks