error when build gridlab-d in ubuntu 11.10

stan
2013-01-09
2016-05-10
  • stan

    stan - 2013-01-09

    Hi everyone,
       When I try to compile the source 2_0_2363, after run ./configure, it keeps give me this error and don't stop until I use control-c.

    stan@stan-PC:~/Downloads/Gridlab-D$ ./configure  
    Packages listed:  core climate commercial network powerflow residential tape plc tape\_file tape\_plot  
    Checking corefound and ready  
    Checking climatefound and ready  
    Checking commercialfound and ready  
    Checking networkfound and ready  
    Checking powerflowfound and ready  
    Checking residentialfound and ready  
    Checking tapefound and ready  
    Checking plcfound and ready  
    Checking tape\_filefound and ready  
    Checking tape\_plotfound and ready  
    All packages are found  
    Updating core/version.h with VERSION info done  
    You may proceed with autoreconf -isf  
    configure.ac:95: error: AC\_SUBST: \`DX\_FLAG\_DX\_CURRENT\_FEATURE' is not a valid shell variable name  
    m4/dx\_doxygen.m4:77: DX\_REQUIRE\_PROG is expanded from  
    m4/dx\_doxygen.m4:117: DX\_ARG\_ABLE is expanded from  
    m4/dx\_doxygen.m4:178: DX\_INIT\_DOXYGEN is expanded from  
    configure.ac:95: the top level  
    autom4te: /usr/bin/m4 failed with exit status: 1  
    aclocal: /usr/bin/autom4te failed with exit status: 1  
    autoreconf: aclocal failed with exit status: 1  
    Packages listed:  core climate commercial network powerflow residential tape plc tape\_file tape\_plot  
    Checking corefound and ready  
    Checking climatefound and ready  
    Checking commercialfound and ready  
    Checking networkfound and ready  
    Checking powerflowfound and ready  
    Checking residentialfound and ready  
    Checking tapefound and ready  
    Checking plcfound and ready  
    .  
    

    Can someone help me about this? I am just beginning to try this software and it cannot compile on neither of my machines.
    thanks

     
    Last edit: David P. Chassin 2016-05-10
  • Jason Fuller

    Jason Fuller - 2013-01-10

    Stan,

    This appears to be v2.0 build (source 2_0_2363)?  Is this right?  If so, we didn't really start supporting GLD in Linux until v2.2, and more robustly, in v2.3 (to be released this month).

    If not, can we get a little more information: linux distro, version of GLD, compiler, etc.

     
  • stan

    stan - 2013-01-16

    Hi Jason,
      Thanks for the reply! Yes, I think it is source 2.0.2363, the one on the sourceforge download web page.  I also check out the branch 2.2 codes, it cannot compile, either. The one can work is the codes in svn trunk.  My machine is Ubuntu 11.10, using Gnu compile tool chain. Thanks!

     
  • Matthew Hauer

    Matthew Hauer - 2013-01-16

    What version of the GNU tools are you using?  We had some hiccups in the GLD 2.2-2.3 transition related to automake.

    -mhauer

     
  • stan

    stan - 2013-01-16

    Hi Matthew,
    Thanks for the reply!  I am using automake  1.11.1 ,autoreconf 2.68 ,gcc  4.6.3 to compile the branch 2.2 code. It doesn't work. But the code inthe svn  trunk works.  My machine is Ubuntu 11.10 x64.  Thanks!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks