Download won't

  • bruce fulton

    bruce fulton - 2008-04-14

    I have a test installation of 2.80 in VMWare workstation v6.0.3 using Ubuntu 7.10 desktop as the guest OS. Greenstone installs without a problem (binaries), and for this exercise I have accepted all defaults. Greenstone itself loads and the demo collection is browseable. GLI will load (although oddly, and perhaps related, I must execute it from the .../gli directory with the command 'bash' as executing './' returns a '.: 96: setup.bash: not found' error, even though setup.bash is located in .../gsdl). When I run the GLI and attempt to download something, it fails to make any kind of connection. For example, I will select OAI and a valid OAI base URL. When I select Server Information, it returns Server information is unavailable. However, I can enter the base URL plus ?verb=Identify in the browser and it returns the appropriate xml. All other network and webserver functions (Apache2) seem to be in proper working order. GLI exits normally without any errors. Any thoughts?

    • Katherine Don

      Katherine Don - 2008-04-17

      Do you need to set up proxy information in GLI? (Click the preferences button on download panel).

      • bruce fulton

        bruce fulton - 2008-04-17

        No, vmware workstation in NAT mode doesn't require proxy settings. It just sets up a virtual LAN with a 192.168.x.x IP address.

        I have tried three or four ground-up installations, and this is completely replicable.

        Interestingly enough, I also tried an alternate installation using v2.74. In that case, I still experienced the same symptoms with GLI and in addition, the web address for the general library wouldn't work. Entering http://greenstone/gsdl/cgi-bin/library resulted in a 404-type error. I could enter http://greenstone/gsdl, and the directory listing included cgi-bin along with all the other directories. The other directories would display contents, but cgi-bin returned a 'not found' error. I chmoded all directories to 777 for trouble shooting purposes, after which nothing at all would load. I reviewed the mods to the apache conf file(in Ubuntu, these are actually stored in /etc/apache2/sites-enabled/000-default, which symlinks to the linux standard httpd.conf) and all appears normal.

        I have not tried earlier versions of Ubuntu yet, although I understand others have been successful at installing on some version or other of Ubuntu using the binaries without having to compile from source. Since this is intended to be a practical lab exercise for student learning, I'd like to try to figure out how to make the binaries work.


Log in to post a comment.