Adding new collection to GreenStone

Help
2004-07-01
2004-07-04
  • shabbir bhimani

    shabbir bhimani - 2004-07-01

    Hello Developers

    I am using Linux Fedora and I have successfully installed apache and GreenStone. Now I want to add the collection but after I pass through the gather --> enrich --> design phase while in create phase when I click Build application it says

    "An error has occured which prevent the collection being previewed"

    Now if I use the collector interface to add a collection it gives the more detailed error as

    "The collection could not be built (import.pl failed).

    The build log contains the following information:

    copying /func.pdf --> /usr/local/gsdl/tmp/tbuild2/shab/import/func.pdf
    importing the shab collection
    build: ERROR: import.pl failed

    Please restart the collector and try again. "

    Hope to hear from you guys soon.
    Shabbir Bhimani

     
    • Michael Dewsnip

      Michael Dewsnip - 2004-07-02

      Hi,

      When you are using the GLI you can increase the amount of information displayed by going to File -> Preferences and changing the mode to "Expert".

      This will hopefully give you a bit more information about what is going wrong when building your collection.

      Regards,

      Michael

       
    • shabbir bhimani

      shabbir bhimani - 2004-07-02

      Command: /usr/local/gsdl/bin/script/import.pl -gli -language en -collectdir /usr/local/gsdl/collect/ shabbir
      import.pl> Uncaught exception from user code:
      import.pl>     Can't load '/usr/local/gsdl/perllib/cpan/auto/XML/Parser/Expat/Expat.so' for module XML::Parser::Expat: /usr/local/gsdl/perllib/cpan/auto/XML/Parser/Expat/Expat.so: undefined symbol: PL_sv_undef at /usr/lib/perl5/5.8.1/i386-linux-thread-multi/DynaLoader.pm line 229.
      import.pl>  at /usr/local/gsdl/perllib/cpan/XML/Parser.pm line 15
      import.pl> Compilation failed in require at /usr/local/gsdl/perllib/cpan/XML/Parser.pm line 15.
      import.pl> BEGIN failed--compilation aborted at /usr/local/gsdl/perllib/cpan/XML/Parser.pm line 27.
      import.pl> Compilation failed in require at /usr/local/gsdl/perllib/plugins/XMLPlug.pm line 36.
      import.pl> BEGIN failed--compilation aborted at /usr/local/gsdl/perllib/plugins/XMLPlug.pm line 36.
      import.pl> Compilation failed in require at /usr/local/gsdl/perllib/plugins/GAPlug.pm line 35.
      import.pl> BEGIN failed--compilation aborted at /usr/local/gsdl/perllib/plugins/GAPlug.pm line 35.
      import.pl> Compilation failed in require at /usr/local/gsdl/perllib/plugin.pm line 67.
      import.pl>     plugin::load_plugins('ARRAY(0x912e63c)',2,'STDERR','import::FAILLOG','ARRAY(0x9202208)') called at /usr/local/gsdl/bin/script/import.pl line 359
      import.pl>     import::main() called at /usr/local/gsdl/bin/script/import.pl line 168
      import.pl> Command failed.

      Following error is generated.

      I get the same error when I user pluginfo.pl as described in developers guide.

      I check the file Expat.so and it exist in the requested folder.

      Also If I use the collector to  upload files files in the / folders is only accepted and from others are not.

      Thanks
      -Shabbir Bhimani

       
    • shabbir bhimani

      shabbir bhimani - 2004-07-02

      I get the same error when I user pluginfo.pl as described in developers guide for the 2 plugins
      GAPlug and XMLPlug
      and for RecPlug it says could not find the plugin

      For GAPlug and XMLPlug following is the text of error
      Uncaught exception from user code:
              Can't load '/usr/local/gsdl/perllib/cpan/auto/XML/Parser/Expat/Expat.so' for module XML::Parser::Expat: /usr/local/gsdl/perllib/cpan/auto/XML/Parser/Expat/Expat.so: undefined symbol: PL_sv_undef at /usr/lib/perl5/5.8.1/i386-linux-thread-multi/DynaLoader.pm line 229.
      at /usr/local/gsdl/perllib/cpan/XML/Parser.pm line 15
      Compilation failed in require at /usr/local/gsdl/perllib/cpan/XML/Parser.pm line 15.
      BEGIN failed--compilation aborted at /usr/local/gsdl/perllib/cpan/XML/Parser.pm line 27.
      Compilation failed in require at /usr/local/gsdl/perllib/plugins/XMLPlug.pm line 36.
      BEGIN failed--compilation aborted at /usr/local/gsdl/perllib/plugins/XMLPlug.pm line 36.
      Compilation failed in require at /usr/local/gsdl/perllib/plugin.pm line 66.
              plugin::load_plugins('ARRAY(0x8e43f40)') called at ./pluginfo.pl line 121
              main::main() called at ./pluginfo.pl line 157

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks