How to Configure Upload to JIRA?

Help
tudorH
2013-02-19
2014-05-21
  • tudorH

    tudorH - 2013-02-19

    Hi,

    I am trying to configure Greenshot so I can upload a screenshot (JPG) to JIRA (On-Premise) however, I am having some troubles. Since there isn't too much documentation on this topic I have no idea how to do it.

    So far I have gone to:
    1. Preferences
    2. Plugins
    3. JIRA Plugin and Configure
    4. Used the URL in the form "http://server:port/rpc/soap/jirasoapservice-v2?wsdl"
    5. And selected file type as JPG

    Now I take a screenshot and select "Upload to JIRA" which gives me another window with fields for JIRA Filter, JIRA, Filename, Comment, Jira....what do I need to put in these fields? The JIRA Filter dropdown does not show any filters so what do I need to do?

    Thanks for any help!

    PS: I have read the other two posts but they did not help me, there was something mentioned about disabling the favorite filters...is this what I need to do and where is this option?

     
  • Robin Krom

    Robin Krom - 2013-02-20

    Hi,

    That you got to the "Upload to JIRA" Window is a good thing, for some functionality an initial login needs to be made!

    So let's see how to get you running.

    The Greenshot plugin has two upload modes:
    1) From the destination picker or editor you can select JIRA and if either a JIRA is opened in the Internet Explorer (e.g. http://server:port/browse/jirakey) or in the ACTIVE Tab of Firefox, than it offers this directly as a destination. It will upload the screenshot directly as attachment, without comment. (This is only available if the current Greenshot instance has been connected to JIRA, otherwise it would show a login after every capture which would be bad.)

    2) Using the upload window, this window apears (after a login) if the JIRA destination is selected when no login has been made or when you select "Upload to JIRA" without JIRA number. As we didn't implement a search, we only support filter, you will either need to input your JIRA Key (at the bottom) or select a filter. The displayed filters, which is currently empty for you, comes from the list of filters you create in JIRA. So if you want to be able to upload to your currently assigned JIRA's you will need to create a filter for this. (I can't really help you with how to create the filters you want, but there should be enough information with Atlassian for this!)

    Let me know if this helps or if you keep having issues.

    Best wishes,
    Robin

     
  • tudorH

    tudorH - 2013-02-21

    Thanks Robin, but I still can't get it to work :(. I tried what you say in (1) and opened the JIRA issue in IE, then I selected a region for my screenshot, selected 'Upload to JIRA' and it prompts me for a username/password but once I enter it nothing happens, no error, nothing.

    Any ideas? The attached screenshot shows what I have configured in the preferences...

     
  • Robin Krom

    Robin Krom - 2013-02-21

    Hi,
    Did you get to select the JIRA ticket in the destination picker?
    This only works if you logged in to JIRA, so getting the upload window once, for every time you start Greenshot again.

    As you didn't get an error, did you check the JIRA ticket for attachments?

    P.s.
    If you change the URL, you will need to restart Greenshot

     
  • tudorH

    tudorH - 2013-02-21

    Got it working! Turns out that was the issue, I didn't restart Greenshot. Now it works fine! Thank you!

     
    Last edit: tudorH 2013-02-21
  • Robin Krom

    Robin Krom - 2013-02-21

    I believe I fixed that for the 1.1...
    Good to hear, have fun!

     
  • Gediminas

    Gediminas - 2014-05-21

    Hello I'm have similar problem, when trying to upload screenshot to jira i use https://192.168.1.9:8080/rpc/soap/jirasoapservice-v2?wsdl address
    and he show me this connection window (16-47-57.png)
    When i enter username name and password, error pops: "There was a problem during the login: the underlying connection was closed: An unexpected error occurred on a send."

    i tried with different users same problem.

     

Log in to post a comment.