#1401 Oracle installer window captures are blank

1.0.6
closed
Capture (303)
fixed
5
2013-02-06
2012-12-03
Anonymous
No

Hi,

Using 1.0.6.2228 on 32-bit WinXP SP3 trying to do window caps for an Oracle ODAC client installation (http://www.oracle.com/technetwork/database/windows/downloads/utilsoft-087491.html -- free registration required to download). The captures appear to work, but the resulting .PNG file is "blank" (all white, but the correct size of the window). I've tried another Java-based installer (jEdit), but window caps on that installer work fine.

A workaround is to do a region capture, but this is more time-consuming. I'm trying to dump SnagIt because Greenshot has been faster/easier to use.

Thanks!

Discussion

  • Robin Krom

    Robin Krom - 2012-12-03
    • milestone: --> 1.0.6
    • assigned_to: nobody --> apex75
     
  • Robin Krom

    Robin Krom - 2012-12-03

    Does this work with SnagIt? I'm surprised the capture is white, would have expected black.
    Could you try to change the windows capture mode to "as displayed" in the settings and try again?

    What version of Windows are you using?

     
  • Rich J

    Rich J - 2012-12-04

    Setting "Window capture mode" to "As Displayed" works! It was set to "Automatic".

    I'll attach a copy of the screenshots with "Automatic" and "As Displayed" to show the difference.

    Thanks!

    p.s. Win version is listed above.

     
  • Rich J

    Rich J - 2012-12-04

    Whoops....apparently I should have been logged in when filing this bug, as it's not letting me attach files. [blush]

    Let me know if you'd like them. The "Automatic" one is white, but the window's title bar and border are black.

    Thanks

     
  • Robin Krom

    Robin Krom - 2013-01-24

    Can you test with the latest 1.1.0? It's still in development but it should be better and this problem should be fixed. If you get to much problems, you should go back to 1.0.6 (but I don't expect you want to)

    You can find it here:
    http://getgreenshot.org/version-history/

     
  • Robin Krom

    Robin Krom - 2013-02-05

    Hi, did you managed to test the 1.1 yet? We unfortunately don't have Windows XP and the problem only shows there.
    Best wishes,
    Robin

     
    • Rich J

      Rich J - 2013-02-05

      Hi Robin,

      Sorry for the delay! I just downloaded 1.1.0 2461, reset Window capture mode back to "Automatically" and the Java caps are all looking great. Bug resolved!

      Thanks much!
      Rich

       
  • Robin Krom

    Robin Krom - 2013-02-06

    Hi Rich,

    thanks for reporting back, closing this bug.

    Best wishes,
    Robin

     
  • Robin Krom

    Robin Krom - 2013-02-06
    • status: open --> closed
    • resolution: --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks