Problem with Green 3.0.0. Help!!!

2008-06-11
2013-04-29
  • zhiguang xu

    zhiguang xu - 2008-06-11

    hi,

    The following is my setup: Eclipse 3.3 + GEF 3.4.0 + Green 3.0.0. It seems everything is installed fine. But when I used Green to generate UML for my classes, I got .grn file with little garbage. When I double clicked the generated .grn file, I got the following exception:

    java.lang.NoClassDefFoundError: com/ibm/icu/text/Bidi

    Can anyone please help?

    Thanks!
    z.x.

     
    • Gene Wang

      Gene Wang - 2008-06-11

      Hi,

        Version 3.0.0 of Green only supports Eclipse 3.3. and GEF 3.3.  It appears that in going to version 3.4, GEF has made some incompatible changes with the Bidi class.  For now, the only way to get Green working would be to downgrade to GEF 3.3.

      - Gene

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks